Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006476 [JEDI VCL] 02 Installation major always 2015-12-08 05:50 2015-12-12 14:31
Reporter Steve009 View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.48
Summary 0006476: Unable to compile with XP Theming enabled
Description Hello support,

IDE/Compiler: Borland C++ Builder 6, running under Windows 7 Ultimate x64

Installed JCL version: Release 2.5 Build 4572
Installing JVCL version: 3.49.0.0
Both the above are from JCL/JVCL Official Release installation file: JVCL349CompleteJCL27-Build5676.zip at: http://sourceforge.net/projects/jvcl/files/JVCL%203/JVCL%203.49/ [^]

I'm getting a compile error when running the JVCL installer with the XP Theming enabled.
The errors are in module: JvThemes.pas(1493)
Undeclared Identifier: TThemeSize'
Undeclared identifier: TS_MIN'
Undeclared identifier: TS_DRAW
Undeclared identifier: 'GetThemePartSize'
See attached image of the actual installer output screen.

With XP Theming disabled the compile/link/component install is perfect.

I have XP theming enabled in a much older, 2008, version of JEDI. So I would be very appreciative if you could point me in the right direction in order to get up to date.

As I'm compiling with BCB 6, I have successfully followed Carmelo Viavattene's instructions to produce the DCP files.

But the instruction to:
"Open jvcl.inc with a text editor and remove the dot in {.$DEFINE JVCLThemesEnabled} before building the jvcl packages"
cannot be done because {.$DEFINE JVCLThemesEnabled} doesn't exist in jvcl.inc. The only reference to this define is on line 319:
{$IFDEF COMPILER7_UP}
 {$DEFINE JVCLThemesEnabled}

So I ignored this instruction.

Thank you.
Additional Information
Tags No tags attached.
Attached Files png file icon JVCL Install Log.PNG [^] (24,225 bytes) 2015-12-08 05:50

- Relationships

-  Notes
(0021256)
AHUser (developer)
2015-12-12 14:31

Fixed in master branch.

- Issue History
Date Modified Username Field Change
2015-12-08 05:50 Steve009 New Issue
2015-12-08 05:50 Steve009 File Added: JVCL Install Log.PNG
2015-12-12 14:31 AHUser Note Added: 0021256
2015-12-12 14:31 AHUser Status new => resolved
2015-12-12 14:31 AHUser Fixed in Version => Daily / GIT
2015-12-12 14:31 AHUser Resolution open => fixed
2015-12-12 14:31 AHUser Assigned To => AHUser
2015-12-14 01:39 Steve009 Issue Monitored: Steve009
2015-12-14 01:40 Steve009 Issue End Monitor: Steve009


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker