Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006501 [JEDI VCL] 00 JVCL Components minor always 2016-03-25 17:11 2019-04-30 15:18
Reporter CDametto View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.48
Summary 0006501: In JvDBGrid, UseThemedHilighlighting leave out columns with checkbox
Description Implementing OnCheckIfBooleanField in a JvDBGrid, the column with checkbox
looks as if UseThemedHilighlighting=False
Additional Information I have solved adding three line in TJvDBGrid.DrawColumnCell routine:

[...]
  if DefaultDrawing then
  begin
    I := GetImageIndex(Field);
    if I >= 0 then
    begin
      Bmp := GetGridBitmap(TGridPicture(I));
      if Highlight then // <- LINE ADDED
        DrawThemedHighlighting(Canvas, Rect) // <- LINE ADDED
      else // <- LINE ADDED
      Canvas.FillRect(Rect);
      DrawBitmapTransparent(Canvas, (Rect.Left + Rect.Right + 1 - Bmp.Width) div 2,
        (Rect.Top + Rect.Bottom + 1 - Bmp.Height) div 2, Bmp, clOlive);
    end
    else
    begin
      DefaultDrawColumnCell(Rect, DataCol, Column, State);
    end;
  end;
[...]
Tags No tags attached.
Attached Files zip file icon Demo.zip [^] (54,257 bytes) 2019-01-25 12:42

- Relationships

-  Notes
(0021491)
obones (administrator)
2018-07-18 15:42

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021604)
CDametto (reporter)
2019-01-25 12:41

The issue is still present in jvcl 3.50 with Delphi 10.3 rio
(0021749)
mh (reporter)
2019-04-26 20:15

Pull request with your proposed fix created:
https://github.com/project-jedi/jvcl/pull/94 [^]

- Issue History
Date Modified Username Field Change
2016-03-25 17:11 CDametto New Issue
2018-07-18 15:42 obones Note Added: 0021491
2018-07-18 15:42 obones Status new => feedback
2019-01-25 12:41 CDametto Note Added: 0021604
2019-01-25 12:42 CDametto File Added: Demo.zip
2019-04-26 20:15 mh Note Added: 0021749
2019-04-30 15:18 obones Status feedback => resolved
2019-04-30 15:18 obones Fixed in Version => Daily / GIT
2019-04-30 15:18 obones Resolution open => fixed
2019-04-30 15:18 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker