Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006518 [JEDI VCL] 00 JVCL Components minor always 2016-07-21 15:11 2019-04-30 16:14
Reporter andreykorol View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0006518: TJvHidDeviceController - missed OnDeviceDataError handler setup
Description TJvHidDevice.CtlCreate constructor is missing setting Controller.OnDeviceDataError to OnDataError. So, in this way TJvHidDeviceReadThread.DoDataError will never call Device.FDataError (user event).
fix patch:
-------------------------------------------------------------------------
diff --git a/JvHidControllerClass.pas b/JvHidControllerClass.pas
index b1f43b2..9264a6e 100644
--- a/JvHidControllerClass.pas
+++ b/JvHidControllerClass.pas
@@ -807,6 +807,7 @@ begin
   FDataThread := nil;
   OnData := Controller.OnDeviceData;
   OnUnplug := Controller.OnDeviceUnplug;
+ OnDataError := Controller.OnDeviceDataError;
 
   FHidFileHandle := CreateFile(PChar(PnPInfo.DevicePath), GENERIC_READ or GENERIC_WRITE,
     FILE_SHARE_READ or FILE_SHARE_WRITE, nil, OPEN_EXISTING, 0, 0);
-------------------------------------------------------------------------
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021504)
obones (administrator)
2018-07-18 15:47

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021772)
mh (reporter)
2019-04-28 10:45

Created pull request for this:
https://github.com/project-jedi/jvcl/pull/107 [^]

- Issue History
Date Modified Username Field Change
2016-07-21 15:11 andreykorol New Issue
2018-07-18 15:47 obones Note Added: 0021504
2018-07-18 15:47 obones Status new => feedback
2019-04-28 10:45 mh Note Added: 0021772
2019-04-30 16:14 obones Status feedback => resolved
2019-04-30 16:14 obones Fixed in Version => Daily / GIT
2019-04-30 16:14 obones Resolution open => fixed
2019-04-30 16:14 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker