Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006538 [JEDI VCL] 00 JVCL Components minor always 2016-12-04 19:28 2019-04-30 16:13
Reporter bflorac View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.48
Summary 0006538: JvHidControllerClass, BusType should be of type TGUID not string
Description According to MS, SetupDiGetDeviceRegistryProperty with SPDRP_BUSTYPEGUID returns a 16 byte GUID not a string.

See function: TJvHidPnPInfo.Create()...
FBusType := GetRegistryPropertyString(APnPHandle, ADevData, SPDRP_BUSTYPEGUID);
Additional Information To make it backward compatible, one could extract as TGUID and convert to string for the object.

New Function:

function TJvHidPnPInfo.GetRegistryPropertyGuid(PnPHandle: HDEVINFO;
  const DevData: TSPDevInfoData; Prop: DWORD): TGuid;
const
  GUID_NULL: TGUID = '{00000000-0000-0000-0000-000000000000}';
var
  BytesReturned: DWORD;
  RegDataType: DWORD;
begin
  BytesReturned := 0;
  RegDataType := 0;
  Result := GUID_NULL;
  SetupDiGetDeviceRegistryProperty(APnPHandle, ADevData, Prop, RegDataType, PByte(@Result), SizeOf(Result), BytesReturned);
end;

And then in TJvHidPnPInfo.Create():
  FBusType := GuidToString(GetRegistryPropertyString(APnPHandle, ADevData, SPDRP_BUSTYPEGUID));

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021507)
obones (administrator)
2018-07-18 15:48

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021770)
mh (reporter)
2019-04-28 09:06

Created a pull request for it, implementing it without local GUID_NULL:
https://github.com/project-jedi/jvcl/pull/106 [^]

- Issue History
Date Modified Username Field Change
2016-12-04 19:28 bflorac New Issue
2018-07-18 15:48 obones Note Added: 0021507
2018-07-18 15:48 obones Status new => feedback
2019-04-28 09:06 mh Note Added: 0021770
2019-04-30 16:13 obones Status feedback => resolved
2019-04-30 16:13 obones Fixed in Version => Daily / GIT
2019-04-30 16:13 obones Resolution open => fixed
2019-04-30 16:13 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker