Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006554 [JEDI VCL] 00 JVCL Components major always 2017-03-23 16:58 2019-04-27 19:04
Reporter JMStoorvogel View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.48
Summary 0006554: D7: JvTreeItemsEditorForm.dfm contains the property "AlignwithMargins" -> designtime error
Description For Delphi 7, the jvcl-master\jvcl\design\JvTreeItemsEditorForm.dfm contains the property "AlignwithMargins" for some TCombobox, which doesn't exist in D7.

Therefore, runtime editing of the TreeView Items does not work.

Resolution:
1. edit the .dfm manually and remove the offending property
2. Rebuild jvcl
Additional Information
Tags AlignwithMargins, Delphi 7.0, JvTreeItemsEditorForm
Attached Files ? file icon JvTreeItemsEditorForm.dfm [^] (7,114 bytes) 2017-03-23 22:31

- Relationships

-  Notes
(0021412)
JMStoorvogel (reporter)
2017-03-23 22:34

Patch is supplied as attached file for the novice user.
(0021515)
obones (administrator)
2018-07-18 15:50

Could you check if the issue is still present in the latest GIT content? If yes, please provide a pull request at Github.
(0021766)
mh (reporter)
2019-04-27 14:46

Added pull request for this, even if I think we could drop D7 support finally. I know this would hurt some folks, but they should really consider upgrading, as there was simply added so much good stuff they miss when sticking to D7... ;-)

https://github.com/project-jedi/jvcl/pull/102 [^]

- Issue History
Date Modified Username Field Change
2017-03-23 16:58 JMStoorvogel New Issue
2017-03-23 22:31 JMStoorvogel File Added: JvTreeItemsEditorForm.dfm
2017-03-23 22:33 JMStoorvogel Tag Attached: Delphi 7.0
2017-03-23 22:33 JMStoorvogel Tag Attached: AlignwithMargins
2017-03-23 22:33 JMStoorvogel Tag Attached: JvTreeItemsEditorForm
2017-03-23 22:34 JMStoorvogel Note Added: 0021412
2018-07-18 15:50 obones Note Added: 0021515
2018-07-18 15:50 obones Status new => feedback
2019-04-27 14:46 mh Note Added: 0021766
2019-04-27 19:04 obones Status feedback => resolved
2019-04-27 19:04 obones Fixed in Version => Daily / GIT
2019-04-27 19:04 obones Resolution open => fixed
2019-04-27 19:04 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker