Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006579 [JEDI VCL] 00 JVCL Components minor always 2017-07-18 19:57 2019-05-02 08:33
Reporter stjcottbus View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006579: JvTFGlance adds an annoying empty line in Hint if ShowSchedNamesInHint is False.
Description In TJvTFCustomGlance.CheckApptHint is the variable ExtraDesc not initialized (may be unneeded) but is unconditionally expanded with CRLF.

It should more or less look like this:

procedure TJvTFCustomGlance.CheckApptHint(Info: TJvTFGlanceCoord);
var
  ExtraDesc: string;
  Handled: Boolean;
begin
  if Assigned(FViewer) and FViewer.ShowSchedNamesInHint then
  begin
    ExtraDesc := StringsToStr(SchedNames, ', ', False);
    ExtraDesc := ExtraDesc + 0000013#10;
  end else
    ExtraDesc := '';
  Handled := False;
  if Assigned(OnApptHint) then
    FOnApptHint(Self, Info.Appt, Handled);
  if not Handled then
    FHint.ApptHint(Info.Appt, Info.AbsX + 8, Info.AbsY + 8,
                   not Assigned(FViewer) or FViewer.ShowStartEndTimeInHint, True, False, ExtraDesc);
end;
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021524)
obones (administrator)
2018-07-18 15:54

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021764)
mh (reporter)
2019-04-27 14:35

Pull request for this one created:
https://github.com/project-jedi/jvcl/pull/100 [^]
(0021793)
jfudickar (developer)
2019-05-02 08:33

Fixed in Repository

- Issue History
Date Modified Username Field Change
2017-07-18 19:57 stjcottbus New Issue
2017-07-20 07:50 stjcottbus Issue Monitored: stjcottbus
2018-07-18 15:54 obones Note Added: 0021524
2018-07-18 15:54 obones Status new => feedback
2019-04-27 14:35 mh Note Added: 0021764
2019-05-02 08:33 jfudickar Note Added: 0021793
2019-05-02 08:33 jfudickar Status feedback => resolved
2019-05-02 08:33 jfudickar Resolution open => fixed
2019-05-02 08:33 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker