Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006607 [JEDI VCL] 00 JVCL Components feature always 2017-12-24 13:25 2018-07-18 15:58
Reporter pyscripter View Status public  
Assigned To obones
Priority normal Resolution no change required  
Status resolved   Product Version Daily / GIT
Summary 0006607: Please remove unnnecessary IFDEFs in JvGnugettext
Description In JvGnugettext there are about 70 lines of IFDEFs such as the following:
{$ifdef VER200}
  // Delphi 2009 with Unicode
  {$DEFINE DELPHI2009OROLDER}
{$endif}

which are not only unnecessary but confusing.

For example in TGnuGettextInstance.TranslateStrings we have the code:

        {$ifdef DELPHI2009OROLDER}
        if Assigned(slAsTStringList) then begin
          originalOwnsObjects := slAsTStringList.OwnsObjects;
          slAsTStringList.OwnsObjects := False;
        end;
        {$endif}

In fact DELPHI2009OROLDER actually means Delphi 2009 or newer!

Since the unit includes JEDI.inc, the above can be replaced with DELPHI12_UP etc.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021532)
obones (administrator)
2018-07-18 15:58

This will not be changed as the unit comes from a third party project that has its own life.

- Issue History
Date Modified Username Field Change
2017-12-24 13:25 pyscripter New Issue
2018-07-18 15:58 obones Note Added: 0021532
2018-07-18 15:58 obones Status new => resolved
2018-07-18 15:58 obones Resolution open => no change required
2018-07-18 15:58 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker