Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006632 [JEDI VCL] 00 JVCL Components minor always 2018-04-05 15:50 2019-04-28 17:59
Reporter Vojtisek View Status public  
Assigned To
Priority normal Resolution open  
Status acknowledged   Product Version Daily / GIT
Summary 0006632: saving with JvSaveDialog
Description We tried to use JvSaveDialog in our C++ project, but we got a issue:
In component we have checked Options -> ofOverwritePrompt.
When we tried to save the file with same name as one already in folder and we didn't get any message about overwriting of file then when we looked to folder file was overwritten.
So for us it seems that option ofOverwritePrompt doesn't work.

We use:
RAD Studio 10 Seattle update 1
JVCL 3.50

additionally I am attaching the zipped file with example code and compiled exe
which demonstrates it.

Thanks in advance.
Additional Information
Tags No tags attached.
Attached Files 7z file icon test.7z [^] (1,300,816 bytes) 2018-04-05 15:50

- Relationships

-  Notes
korecek (reporter)
2018-04-05 18:34

In addition ...
There is also problem with save button which is set to "Open" instead of "Save".
Default setting of title bar is also set to Open...???
It is major severity in my opinion.
mh (reporter)
2019-04-28 17:59

About the wrong button captions and the title bar: could it be because TJvSaveDialog inherits from TJvOpenDialog which inherits from TOpenDialog?

What would happen, if we implemented TJvSaveDialog analog to TJvOpenDialog and inheritig from TSaveDialog then?

Or is there an easier way to fix this available?

- Issue History
Date Modified Username Field Change
2018-04-05 15:50 Vojtisek New Issue
2018-04-05 15:50 Vojtisek File Added: test.7z
2018-04-05 18:34 korecek Note Added: 0021462
2018-07-18 16:07 obones Status new => acknowledged
2019-04-28 17:59 mh Note Added: 0021776

Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker