Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006634 [JEDI VCL] 00 JVCL Components minor always 2018-04-17 14:39 2018-10-02 09:22
Reporter tstoicescu View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006634: Access violation in Jedi/Jvcl/Run/JvclUtils.pas
Description Access violation in Jedi/Jvcl/Run/JvclUtils.pas
in: GetWordOnPos2(s = '', P>0)..
in: if CharInSet(S[P], Separators) and ((P < 1) or CharInSet(S[P - 1], Separators)) then

from: Jedi/Jvcl/Run/JvEditor.Pas
TJvCompletion.FindSelItem
 S := GetWordOnPos2(Ed.FLines[Ed.CaretY], Ed.CaretX, iBeg, iEnd)
where Ed.FLines[Ed.CaretY] = EmptyStr and Ed.CaretX > 0,
because a line ' 22 ' edit in runtime, after deleting '22'.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021463)
tstoicescu (reporter)
2018-04-17 14:57

0I think may be like in GetWordOnPos

....
if (P > Length(S)) or (P < 1) then
    Exit;
...

not only

....
if (P < 1) then
    Exit;
.....
(0021553)
obones (administrator)
2018-07-18 16:07

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021579)
AHUser (developer)
2018-10-02 09:22

Fixed in git master

- Issue History
Date Modified Username Field Change
2018-04-17 14:39 tstoicescu New Issue
2018-04-17 14:55 tstoicescu Issue Monitored: tstoicescu
2018-04-17 14:57 tstoicescu Note Added: 0021463
2018-07-18 16:07 obones Note Added: 0021553
2018-07-18 16:07 obones Status new => feedback
2018-10-02 09:22 AHUser Note Added: 0021579
2018-10-02 09:22 AHUser Status feedback => resolved
2018-10-02 09:22 AHUser Fixed in Version => Daily / GIT
2018-10-02 09:22 AHUser Resolution open => fixed
2018-10-02 09:22 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker