Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006635 [JEDI VCL] Miscellanous major have not tried 2018-05-24 10:14 2018-06-08 11:11
Reporter DmitryBelkevich View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0006635: Some fixes
Description It's need to make some fixes into different files.
Additional Information 1. 64 bits compatiblity

a) Change Pointer(Cardinal to Pointer(NativeUInt
Files JvAddPrinter.pas, JvThemes.pas
b) Longint(Self) to NativeUInt(Self)
Files JvBDEFilter.pas, JvBDEProgress.pas
c) In file JvDataProvider.pas:
change Result := Pointer(Cardinal(RAPI.GetProc) and $00FFFFFF + Cardinal(Self) + 4);
to Result := Pointer(NativeUInt(RAPI.GetProc) and $00FFFFFF + NativeUInt(Self) + 4);

2. Add CheckAll method to the TJvCheckTreeView class:

procedure TJvCheckTreeView.CheckAll(CheckState: boolean);
var
  I: Integer;
begin
  for I := 0 to Items.Count - 1 do
    TJvTreeNode(Items[i]).Checked := CheckState;
end;

3. Modify TJvPropertyStoreEditorControl.SetPropertyStore method:

procedure TJvPropertyStoreEditorControl.SetPropertyStore(const Value: TComponent);
begin
  if csDestroying in Componentstate then
    Exit;

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021468)
AHUser (developer)
2018-06-08 11:11

Fixed in master branch.

The BDE Units are not fixed because there is no 64 bit BDE and the expected function parameter is "Longint"

- Issue History
Date Modified Username Field Change
2018-05-24 10:14 DmitryBelkevich New Issue
2018-05-24 10:14 DmitryBelkevich IDE version => All
2018-06-08 10:12 AHUser Project JEDI Code Library => JEDI VCL
2018-06-08 11:11 AHUser Note Added: 0021468
2018-06-08 11:11 AHUser Status new => resolved
2018-06-08 11:11 AHUser Fixed in Version => Daily / GIT
2018-06-08 11:11 AHUser Resolution open => fixed
2018-06-08 11:11 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker