View Issue Details

IDProjectCategoryView StatusLast Update
0006682JEDI VCL00 JVCL Componentspublic2019-08-24 01:41
ReporterOuatuBogdanAssigned ToAHUser 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in VersionDaily / GIT 
Summary0006682: loop on WM_DRAWITEM
DescriptionFrom last update:
at line: 1839 SetDefaultMenuFont(Screen.MenuFont)
in JvMenus: TJvPopupMenu.WMDrawItem starts a infinite loop with FORMS: TCustomForm.WndProc at WM_DRAWITEM.

Just right-click to get pop-up menu, draws menu items again an again.
Additional Informationremedy:
Canvas.Font := Screen.MenuFont;
instead of offending line
TagsNo tags attached.

Activities

2019-05-31 18:56

 

PopupTest.zip (54,740 bytes)

mh

2019-05-31 18:58

reporter   ~0021855

Hello,

I cannot reproduce your problem.
What I did can be seen in the attached demo.

1. Unzip it and run it.
2. right click into the edit at the bottom

On my Windows 10 x64 VM this opens a TJvPopupMenu with 2 entries, both call ShowMessage each and I do not see any flicker. I can click them and they bring up their message each.

=> how does your test case differ?

mh

2019-06-15 16:16

reporter   ~0021857

@OuatuBogdan: did you check my demo in order to tell us what you make different in order to actually show the bug?

mh

2019-08-20 18:19

reporter   ~0021881

@OuatuBogdan: did you check my demo meanwhile? If you tell us what I did differently so I do not see this issue I'll try to help getting it fixed. until then I cannot do anything about that opne. Sorry!

AHUser

2019-08-24 01:29

developer   ~0021885

The JvPopupMenu.Style must be changed to msXP so that SetDefaultMenuFont is called.

The SetDefaultMenuFont(Screen.MenuFont) call doesn't change the font of the Canvas, but changes the Screen.MenuFont itself what causes an application-wide redraw.

Issue History

Date Modified Username Field Change
2019-05-30 12:07 OuatuBogdan New Issue
2019-05-31 18:56 mh File Added: PopupTest.zip
2019-05-31 18:58 mh Note Added: 0021855
2019-06-15 16:16 mh Note Added: 0021857
2019-08-20 18:19 mh Note Added: 0021881
2019-08-24 01:29 AHUser Note Added: 0021885
2019-08-24 01:41 AHUser Assigned To => AHUser
2019-08-24 01:41 AHUser Status new => resolved
2019-08-24 01:41 AHUser Resolution open => fixed
2019-08-24 01:41 AHUser Fixed in Version => Daily / GIT