View Issue Details

IDProjectCategoryView StatusLast Update
0001853JEDI VCL02 Installationpublic2004-06-18 12:16
ReporteranonymousAssigned ToAHUser 
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001853: The installer always fails, trying to access really strange directories
DescriptionI have downloaded the complete install pack ( from the "JVCL Releases" section of the SourceForge site. I have also, before this, downloaded and installed JCL 1.91.

Now, when I run the JVCL install.bat, the GUI installer is compiled and started, and I can put a checkmark in the "Delphi 7 CSS" box without any trouble (before this, I tried the same thing without having installed JCL, and then it prompted me to browse to the JCL root directory, and whatever I selected it complained that the "\source\common" subdir wasn't found, which was of course quite normal because I hadn't installed JCL at all, but now I have, and that part is ok).

BUT, as soon as I press the "Install" button now in the JVCL installer, after selecting the "Delphi 7 CSS" box, it brings up the install progress dialog, but fails almost immediately. :-( When I check in the log, the error is "Fatal: File not found: 'JclSysUtils.dcu'". When I look above this error in the log, I can see that it has tried to call dcc32.exe with a lot of incorrect directories (seemingly meant to point into the JCL/JVCL directories), pointing to non-existing locations, which explains why that file could not be found. The question is why is does this, and not pointing to the correct directories, which it has obviously detected, because it did not complain any longer when selecting the Delpi 7 checkbox, as described above.

Here is the failing call to dcc32.exe from the log:
** Generating packages...

MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
    "D:\program\3\borland\Delphi7\bin\dcc32.exe" -e"..\Bin" -i"..\..\Run;..\Common;..\..\Common;..\..\..\jcl\source;..\..\..\jcl\source\common;..\..\..\jcl\source\windows;..\..\..\jcl\source\vcl;..\..\..\jcl\source\visclx;..\..\Archive;..\Dcu" -n"..\Dcu" -r"..\..\Run;..\Common;..\..\Common;..\..\..\jcl\source;..\..\..\jcl\source\common;..\..\..\jcl\source\windows;..\..\..\jcl\source\vcl;..\..\..\jcl\source\visclx;..\..\Archive;..\Dcu" -u"..\..\Run;..\Common;..\..\Common;..\..\..\jcl\source;..\..\..\jcl\source\common;..\..\..\jcl\source\windows;..\..\..\jcl\source\vcl;..\..\..\jcl\source\visclx;..\..\Archive;..\Dcu" -q -w -h -m pg.dpr
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
GenerateUtils.pas(43) Fatal: File not found: 'JclSysUtils.dcu'

As you can see, it seemingly tries to pass all paths in the form of relative paths for some reason, but all these relative paths are incorrect and nonexisting! Why does it think it will find anything there?

If it is of any use, the path to my installed JCL is:


and the path from which I'm running the installation (i.e. the directory to which I unpacked the JVCL install zip archive and am running install.bat from) is:


Finally, as can also be seen in the log dump above, the path of my dc32.exe is:


A wild guess is that there's a bug in your code that generates the relative paths, giving an incorrect result when it is trying to generate a relative path from "D:\program\3\borland\Delphi7\bin" to "D:\program\11\jcl191" which it then passes on to the compiler, or what do you think?

Please take a look at this, and try to fix it, because I really want to install this nice library.

My email address is "", if you want some further details or have some tips/help/workaround for me.

One question: Will there be any changes to my system left now when the installation has failed, or can I safely assume that everything is like before, not having to expect any problems from a semi-completed installation?

Thanks a lot, keep up the great work!

TagsNo tags attached.



2004-06-11 14:00

viewer   ~0004538 is very old.
Better try with daily snapshot from:


2004-06-18 10:30

viewer   ~0004585

I can confirm both the reported problem and the solution. The daily snapshot worked great. This bug can be closed, though it would be nice to have 06/17's snapshot up on SF.


2004-06-18 12:16

developer   ~0004587

Fixed in newer JVCL 3 versions.

Issue History

Date Modified Username Field Change
2004-06-11 13:34 anonymous New Issue
2004-06-11 14:00 anonymous Note Added: 0004538
2004-06-18 10:30 anonymous Note Added: 0004585
2004-06-18 12:16 AHUser Status new => resolved
2004-06-18 12:16 AHUser Resolution open => fixed
2004-06-18 12:16 AHUser Assigned To => AHUser
2004-06-18 12:16 AHUser Note Added: 0004587