View Issue Details

IDProjectCategoryView StatusLast Update
0002195JEDI VCL00 JVCL Componentspublic2004-10-07 05:35
ReporteranonymousAssigned Touser72 
Status resolvedResolutionno change required 
Product Version3.00 BETA 2 
Target VersionFixed in Version 
Summary0002195: JvJVCLAAboutForm call to JclWin32.GetversionInfo has not same parameter type
DescriptionDifferent declarations in JclWin32 and JvJVCLAboutForm.pas
Additional InformationLoaded JCL v. and,but get error at statement JclWin32.GetVersionEx(VersionInfo); in FormShow in JvJVCLAboutForm.pas.
Here VersionInfo is declared as
  VersionInfo: TOSVersionInfoEx;

while in Jclwin32 the GetVersionEx is declared with

function GetVersionEx(lpVersionInformation: POSVersionInfoEx): BOOL; stdcall;


  POSVersionInfoEx = ^TOSVersionInfoEx;
  TOSVersionInfoEx = record

What is the correct declaration in JvJVCLAboutform.pas __
TagsNo tags attached.


has duplicate 0002641 resolvedremkobonte Error JvJvclAboutForm.pas(132) univompatible Types TosVersionInfoEx and PosVersionEx 



2004-10-04 23:34


Please don't mix different old and new versions of JCL and JVCL. You can get the latest JCL from and the latest JVCL from


2004-10-05 07:29

viewer   ~0005309

Hm. After downloading the two files and putting them in place the jvcl is put in place, if I don't check the build box. Checking the build box, I still get the error mentioned :-(

But, worse. After doing this Delphi 6 starts snuggly, but Delphi 5 Pro show up a message saying "PROJECTS macro in project group file is missing or incorrect" :-(

Where do I find the file in error blocking me from starting Delphi at all. (Afterwards I have to type Ctrl-Alt-Del and kill the idling delphi32.exe in order to try again)


2004-10-05 09:28

viewer   ~0005312

Trying to compile using Delphi 5 from another account where I don't get the error mentioned previously (PROJECTS macro in project group etc.), I get new errors.

Trying to compile JvExMask gives error [Fatal Error] plot.pas(80): Unit JvExMask was compiled with a different version of JvTypes.TJvClipboardCommands

JvExControls displays: [Fatal Error] plot.pas(81): Unit JvExControls was compiled with a different version of JvTypes.IInterface

JvComponent gives: [Fatal Error] plot.pas(83): Unit JvFunctions was compiled with a different version of JclStrings.CharIsNumber

JvSpin gives: [Fatal Error] plot.pas(83): Unit JvFunctions was compiled with a different version of JclStrings.CharIsNumber and the same error is occuring if the first uses statement is JvDPSpinEdit

I have installed the latest version of both Jcl and Jvcl and previously removed all sources from earlier versions at least as far as I know.


2004-10-05 11:17


How do you install? Do you run install.bat from jcl and then install.bat from jvcl or are you doing it manually?


2004-10-06 14:14

viewer   ~0005329

Yes, I did so.

But after repeating trouble I did a new search for old dcu-files and found some that has passed in wrong directories (/bin). After removing and three times recompiling,then build worked and all problems disappeared.

I have now started testing if the different components has some explainments in the help file.

Any interest in feedback??


2004-10-07 05:34


> Any interest in feedback??
Of course. Always :)

Issue History

Date Modified Username Field Change
2004-10-04 14:48 anonymous New Issue
2004-10-04 23:34 user72 Note Added: 0005297
2004-10-04 23:34 user72 Status new => feedback
2004-10-05 07:29 anonymous Note Added: 0005309
2004-10-05 09:28 anonymous Note Added: 0005312
2004-10-05 11:17 user72 Note Added: 0005313
2004-10-06 14:14 anonymous Note Added: 0005329
2004-10-07 05:34 user72 Note Added: 0005332
2004-10-07 05:35 user72 Status feedback => resolved
2004-10-07 05:35 user72 Resolution open => no change required
2004-10-07 05:35 user72 Assigned To => user72
2005-02-14 15:41 remkobonte Relationship added has duplicate 0002641