View Issue Details

IDProjectCategoryView StatusLast Update
0005173JEDI VCL02 Installationpublic2011-06-07 17:23
ReporterIanJ0208Assigned Toobones 
Status resolvedResolutionfixed 
Product Version3.39 
Target VersionFixed in Version 
Summary0005173: JCL 2.1 or higher not installed
DescriptionI've seen this problem reported by others so I thought I would chuck in my $0.02.

I upgraded to Delphi 2010 and uninstalled the old one. The problem would seem to be with all versions of the VCL as I first used the old version (3.38 I think) to install to my new version of Delphi. I accepted the defaults and everything was ok. I then realised that I didn't want it installed in the default location, so I uninstalled and tried to reinstall to the path that I wanted. It barfed with 'JCL 2.0 or higher not installed'. I did a Google and found a post indicating a registry cleaning issue.

I uninstalled the JCL and ran Eusing and tried again to reinstall. No go with the JVCL again. I uninstalled the JCL and downloaded the latest zip file (3.39/3536). I installed the JCL at the path I wanted, but again it wouldn't let me install JVCL, this time with 'JCL 2.1 or higher not installed'. Again, I uninstalled and tried the installation again, accepting the default path. Everything works fine.

It only seems to like going where *it* wants to go.

TagsNo tags attached.



2010-02-22 09:59

administrator   ~0017205

Have you actually cleaned the registry?
And for what version of Delphi does it complain?


2010-02-27 21:59

reporter   ~0017218

Sorry, I don't quite understand what you mean. I ran Eusing over the Registry, so I guess it was as clean as that app gets it. And I upgraded to 2010 from D5. The original VCL (3.38?) reinstalled alright. I upgraded to 3.39/3536 and had problems.

Does that help any?


2010-03-01 09:56

administrator   ~0017219

But you never indicate if you updated the JCL (not JVCL) as well when migrating to JVCL 3.39


2010-03-01 17:58

reporter   ~0017221

Sorry, yes, I updated the whole nine yards. I did a complete uninstall. I still have fond memories of spending many a happy hour trying to get version 1.something to install many years ago. :) I uninstall first.


2010-10-08 14:07

administrator   ~0017765

Does this still happen with the latest JCL and JVCL versions?


2011-06-07 17:23

administrator   ~0018564

No news, I'm assuming this is fixed

Issue History

Date Modified Username Field Change
2010-02-20 08:45 IanJ0208 New Issue
2010-02-22 09:59 obones Note Added: 0017205
2010-02-22 09:59 obones Status new => feedback
2010-02-27 21:59 IanJ0208 Note Added: 0017218
2010-03-01 09:56 obones Note Added: 0017219
2010-03-01 17:58 IanJ0208 Note Added: 0017221
2010-10-08 14:07 obones Note Added: 0017765
2011-06-07 17:23 obones Note Added: 0018564
2011-06-07 17:23 obones Status feedback => resolved
2011-06-07 17:23 obones Resolution open => fixed
2011-06-07 17:23 obones Assigned To => obones