View Issue Details

IDProjectCategoryView StatusLast Update
0006655JEDI VCL00 JVCL Componentspublic2019-04-27 15:44
Reporterplipla1Assigned Tojfudickar 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product VersionDaily / GIT 
Target VersionFixed in Version 
Summary0006655: Delphi 10.3 JVCL installation impossible
DescriptionInstalling JCL is possible. But only when cloning from GIT. Downloading a ZIP from GIT and manually pasting jedi.inc won't work.

Here the major / blocking problem:
installing JVCL is completely impossible with Delphi 10.3

While the installer can get compiled and executed, clicking on Install (Win32 and W64) it stops compiling instantly with

...\lib\jvcl-2018\run\JvAppIniStorage.pas(248) Error: E2003 Undeclared Identifier: 'IndexOf'
...\lib\jvcl-2018\run\JvAppIniStorage.pas(257) Error: E2010 Incompatible types: 'TStringList' und 'TMemIniFile.TSections'

Needs a fix fast.
TagsNo tags attached.

Relationships

duplicate of 0006665 new 10.3 Rio Update 1: Installer fails to compile JvAppIniStorage.pas 

Activities

pka4916

2018-11-22 03:28

reporter   ~0021591

Same problem.
Downloaded from GitHub. Did stated that it was 10.3 Compatible.

2018-11-23 04:15

 

jvcl-run.zip (53,354 bytes)

cacofony

2018-11-23 04:18

reporter   ~0021592

I have attached some modified file, these changes allow me to compile on Rio. I have not tested any backwards compatibility.

Primary issues

DWL_MSGRESULT; not assigned in JvDialogs , so just changed to 0
procedure TJvOpenDialog.WndProc(var Msg: TMessage);
SetWindowLong(Handle, 0, Result);

TCollectionNotification prefix for cnAdded, cnExtracting,cnDeleting
in jvTabBar, jvSimScope, jvScheduledEvents, jvListComb, jvtimerList


Removal of all {$IFDEF DELPHI2009_UP} code in JvAppIniStorage

2018-12-04 13:55

 

514.gz (10,334 bytes)

jfudickar

2018-12-04 22:46

developer   ~0021593

Please do a complete fresh download and rebuild all sources.
I had no problem to install it into 10.3

jfudickar

2018-12-04 22:46

developer   ~0021594

Please do a complete fresh download and rebuild all sources.
I had no problem to install it into 10.3

Markus34

2018-12-17 12:55

reporter   ~0021599

Please do a complete fresh download and rebuild all sources.
I also had no problem to install it into 10.3
__________
0006655 https://goo.gl/rEgccS

mh

2019-03-07 21:03

reporter   ~0021615

This one is a partial duplicate of this report, but the duplicate contains more in depth information about the JvAppIniStorage issue:
http://issuetracker.delphi-jedi.org/view.php?id=6665

jfudickar

2019-04-27 15:44

developer   ~0021769

Seems to be duplicated

Issue History

Date Modified Username Field Change
2018-11-21 22:00 plipla1 New Issue
2018-11-22 03:28 pka4916 Note Added: 0021591
2018-11-23 04:15 cacofony File Added: jvcl-run.zip
2018-11-23 04:18 cacofony Note Added: 0021592
2018-12-04 13:55 Markus34 File Added: 514.gz
2018-12-04 22:46 jfudickar Note Added: 0021593
2018-12-04 22:46 jfudickar Note Added: 0021594
2018-12-04 22:46 jfudickar Status new => feedback
2018-12-17 12:55 Markus34 Note Added: 0021599
2019-03-07 21:03 mh Note Added: 0021615
2019-04-27 15:44 jfudickar Note Added: 0021769
2019-04-27 15:44 jfudickar Relationship added duplicate of 0006665
2019-04-27 15:44 jfudickar Duplicate ID 0 => 6665
2019-04-27 15:44 jfudickar Status feedback => resolved
2019-04-27 15:44 jfudickar Resolution open => fixed
2019-04-27 15:44 jfudickar Assigned To => jfudickar