Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001455 [JEDI VCL] 00 JVCL Components minor always 2004-03-09 01:21 2004-04-22 02:56
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0001455: Incorrect painting of TJVLabel when resized
Description Incorrect painting of TJVLabel when resized on autosize=true
Could be solved with calling "AdjustBounds" at end of paint procedure.. (Same like in JVCL 2)

procedure TJvCustomLabel.Paint;
var
  Rect: TRect;
  DrawStyle: Integer;
begin
   .....
   .....
    if FShowFocus and Assigned(FFocusControl) and FFocused and
      not (csDesigning in ComponentState) then
    begin
      InflateRect(Rect, 1, 0);
      Brush.Color := Self.Color;
      DrawFocusRect(Rect);
    end;
    AdjustBounds; // <--- Autosize don´t work without
  end;
end;

Best regards

Dierk
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0003270)
user72
2004-03-09 01:38

Have you tested the proposed change with WordWrap = true and AutoSize = true? IIRC, there were problems with AdjustBounds so that's why it was removed, but I could be wrong...

Besides, I think the problem is only apparent when you drop the label on a form, isn't it? Toggling AutoSize off/on will fix it, IIRC.
(0003271)
anonymous (viewer)
2004-03-09 01:56

I have tried all the possibilities in JVCL2.1.
Now it´s the same problem in JVCL3.

You´re right. The problem is only apparent on dropping the label to form, using the label on normal purpose.
In my programm I have to resize the whole form with all components on it in proportion. Therefore this occurs maybe only in my application. :)

BTW: Never had problems with this AdjustBounds

Regards

Dierk
(0003275)
user72
2004-03-09 02:20

I just tested. You're right: it works with both WordWrap and AutoSize in any combination. I'll fix it in CVS. Thanks

- Issue History
Date Modified Username Field Change
2004-03-09 01:21 anonymous New Issue
2004-03-09 01:38 user72 Note Added: 0003270
2004-03-09 01:38 user72 Status new => feedback
2004-03-09 01:56 anonymous Note Added: 0003271
2004-03-09 02:20 user72 Status feedback => resolved
2004-03-09 02:20 user72 Resolution open => fixed
2004-03-09 02:20 user72 Assigned To => user72
2004-03-09 02:20 user72 Note Added: 0003275
2004-04-22 02:56 user72 Status resolved => closed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker