Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001674 [JEDI VCL] 00 JVCL Components feature always 2004-04-20 13:13 2005-04-01 05:50
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001674: Row height, graphics and memo fields in TJvDBGrid
Description It would be nice to change Row heigh on TJvDBGrid. With this change we could also show graphic fields and memo fields. Of course the problem is how we should tell to the grid that some blob field should be displayed as graphic or as memo, may be can be new properies such "GraphicFields" and/or "MemoFields" setting to something like 'Field1;Field2'.
Additional Information For the loading mechanism of graphics fields we can use the same as TJvDBImage
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0003986)
user72
2004-04-22 00:22

The proposed changes are not that easy to implement (IIRC, DBGrid sets the row height based on the font size and it's not so easy overriding that) and will probably not be done any time soon.

If someone feel up to it, please feel free to implement.
(0004335)
user72
2004-05-24 01:18

JvDBGrid will probably be merged with recently donated UltimDbGrid soon, so I don't think we will see any fixes before that
(0004616)
anonymous (viewer)
2004-06-24 09:00

Last bug note was a month ago.
AFAIK Peter will not have time to do that, I could do it but I will need support since Im more core developer than GUI.

ssamayoa
(0006806)
obones (administrator)
2005-04-01 05:50

From Fred and Dom:
the RowsHeight and ShowMemo features have been implemented some
months ago and the display of graphic fields is left to users (an
example is provided for JvDBUltimGrid in the Examples folder)

- Issue History
Date Modified Username Field Change
2004-04-20 13:13 anonymous New Issue
2004-04-22 00:22 user72 Note Added: 0003986
2004-04-22 00:22 user72 Status new => acknowledged
2004-05-24 01:18 user72 Note Added: 0004335
2004-06-24 09:00 anonymous Note Added: 0004616
2005-04-01 05:50 obones Status acknowledged => resolved
2005-04-01 05:50 obones Fixed in Version => 3.00
2005-04-01 05:50 obones Resolution open => fixed
2005-04-01 05:50 obones Assigned To => obones
2005-04-01 05:50 obones Note Added: 0006806


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker