Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000200 [JEDI VCL] 00 JVCL Components feature always 2002-07-21 18:59 2005-08-10 08:34
Reporter Arioch View Status public  
Assigned To obones
Priority none Resolution fixed  
Status resolved   Product Version 1.32
Summary 0000200: update to JvComCtrls: TJVPageControl
Description 0) {$IFDEF LINUX} This unit is only supported on Windows! {$ENDIF}
I think there should not be such a line!
We should check for {$IfNDef WIN32} instead
Or better we should rely on Jedi.Inc - see extra info in attached file.

Also i integrated one of my components - i contributed it as PCHints.zip. Later i'll do it with RxCheckBox.

Also - icon for TJvPageControl updated.
I wonder, Do delphi support palletised 16-coloured bitmaps?
ImageEdit - do not :(
Additional Information
Tags No tags attached.
Attached Files zip file icon PageControl.zip [^] (13,689 bytes) 2002-07-21 19:00
7z file icon hpc_demo.7z [^] (12,253 bytes) 2003-06-27 14:43
png file icon 200-hpc_demo.png [^] (12,125 bytes) 2003-06-28 15:50
zip file icon 200-hpc_demo.Zip [^] (13,325 bytes) 2003-06-28 15:52
zip file icon TestCase_Sources.zip [^] (6,242 bytes) 2004-11-11 15:05
zip file icon TestCase_EXE.zip [^] (190,369 bytes) 2004-11-11 15:05

- Relationships

-  Notes
(0000309)
Arioch (developer)
2002-07-25 04:54

i fix (re-query hint, when mouse is moving over items of the control)

In CMShowHitn method:
Find:
    if Choice=cT then HintStr:=GetShortHint(Tab.Hint);
Change to:
    if Choice=cT then begin
       HintStr:=GetShortHint(Tab.Hint);
       CursorHint:=TabRect(TabNo);
    end;
(0002226)
user72
2003-06-18 06:25

This will be revisited when updating to JVCL 3.0
(0002260)
user72
2003-06-25 15:37

I tested this but it seems CM_HINTSHOW is never called (in D6)? Also, D6 and D7 displays the tabs hint when the mouse is over the tab client area and the page control hint when the mouse is over the tab. Isn't this what your code does as well (or would do if it worked)?
(0002265)
Arioch (developer)
2003-06-27 14:46

as: demo is for Delphi7, You may unpack with http://sevenzip.sf.net [^]

by default it works exactly in standard PageControl manner.
But change HintSource property - and try again.

Just hold the mouse (i needed to click on PageControl before :( ) over tab #3 (not sheet) for both PageControls and compare hints.
(0002268)
user72
2003-06-28 08:17

Please use zip when you upload files. I am not going to install yet another compression program just to unpack this demo and I seriously doubt that anyone else will either.
(0002278)
Arioch (developer)
2003-06-28 15:50

I'm seriously thinking about using 7zip:

Solid archiving will save A LOT of spaces.
Some times ago You told RAR will never be used since it is commercial software.
No i'd like You to consider 7-zip cause it is GPLed freeware and packs the same good as RAR (smth better, smth worse)
And to the end it has it's own 2-paneled file manager :-)

I'll repack to ZIP, but indeed 7-zip is MUCH stronger than any other zero-priced archiver, and there is nothing bad to give it a try.


also i'll post a sreenshot, so take a look at hints displayed for:
TForm, TabSheet1 for both original and modified TPageControl, tab associated to TabSheet1 for both..., tab associated to TabSheet3....

And sure you can take latest sources from demo, or You can take original zip and apply the patch above :-)
(0002470)
anonymous (viewer)
2003-08-27 04:04

PS: latest separate version is http://arioch.nm.ru/Delphi/PCHints/ [^]
Currently there is nothing different from this one (i hope)
(0005612)
Arioch (developer)
2004-11-11 15:04

The bugs are still here.
Year after i told about them in jedi.vcl newsgroup and gave fixes, and heard a replies...

Pity.
I wonder why this donation was accepted, if later it was broken and was never fixed ?
(0005618)
user72
2004-11-12 11:22

What bugs? The only difference I can see is the CursorRect assignment for Tab hints. Is there any more?
(0005619)
Arioch (developer)
2004-11-12 12:52

There were more. In the versions i posted to jedi.vcl.
I don't have them on the fingertips, so i hope someone else do.

Did You run testcase?
There is told all the troubles.
(0005620)
user72
2004-11-12 13:26

>Did You run testcase?
I made my own with the TJvPageControl and the only issue is that when the mouse is over the tab page (not the tab itself), no CM_HINTSHOW is sent to the PageControl, so we can't modify the behavior in that case.

Other than that, i couldn't find anything that was misbehaving.
(0005621)
Arioch (developer)
2004-11-12 14:19

Let's discuss it in the newsgroup beter, ok ?

>no CM_HINTSHOW is sent to the PageControl, so we can't modify the behavior in that case.
And it should not IMHO, so i do not know, what you called an issue and how You need to change behavior.

>> Did You run testcase? There is told all the troubles
> I made my own
I just want to repeat, that TestCase is self-documented, as every good testcase is to be.
I can paste DFM text here of course, but it is simplier IMHO to run test and read what is written on its form :-)
(0005624)
user72
2004-11-13 14:30

An update is committed to CVS
(0005775)
obones (administrator)
2004-11-30 04:38

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 14 days, we will consider this issue fixed.
(0005845)
Arioch (developer)
2004-12-09 11:21

i did not look the code yet, i just recompiled my testcase with daily update

Test 2 - seems to be fixed
Test 1 - Move mouse cursot over Tab 2 until hint for TabSheet 2 pops up.
Then move mouse to the right, until hint for the Main PageControl pops up.
After that move mouse back to Tab 2 - hint should change, but it does not.
(0007782)
obones (administrator)
2005-08-10 08:34

I'm marking this as resolved because test 1 is ok.
Further to this, I tried to reproduce test 2, but the hint only shows up when the tabsheet is active, not when merely hovering its tab. Please post a new issue if need be.

- Issue History
Date Modified Username Field Change
2004-01-27 01:51 user72 Status assigned => closed
2004-11-11 15:04 Arioch Status closed => feedback
2004-11-11 15:04 Arioch Resolution open => reopened
2004-11-11 15:04 Arioch Note Added: 0005612
2004-11-11 15:05 Arioch File Added: TestCase_Sources.zip
2004-11-11 15:05 Arioch File Added: TestCase_EXE.zip
2004-11-11 15:09 Arioch Issue Monitored: Arioch
2004-11-12 11:22 user72 Note Added: 0005618
2004-11-12 12:52 Arioch Note Added: 0005619
2004-11-12 13:26 user72 Note Added: 0005620
2004-11-12 14:19 Arioch Note Added: 0005621
2004-11-13 14:30 user72 Note Added: 0005624
2004-11-15 14:58 user72 Assigned To user72 =>
2004-11-30 04:38 obones Note Added: 0005775
2004-12-09 11:21 Arioch Note Added: 0005845
2005-08-10 08:34 obones Status feedback => resolved
2005-08-10 08:34 obones Resolution reopened => fixed
2005-08-10 08:34 obones Assigned To => obones
2005-08-10 08:34 obones Note Added: 0007782


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker