Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002046 [JEDI VCL] 00 JVCL Components crash always 2004-08-09 23:22 2004-10-05 11:28
Reporter Reino View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002046: TjvPageControl error in win98 en win2000 pro
Description Applications do not start in win98 and crashes with an error in de user.dll and in win2000 with an error in the ntdll.dll
This happens when all the tabs are selected : not visible
Additional Information The error is the file JvComCtrls.pas in the procedure TJvPageControl.SetHideAllTabs(const Value: Boolean); The line : if FHideAllTabs then TabStop := False; triggered the error.
Tags No tags attached.
Attached Files ? file icon JvComCtrls.pas [^] (50,700 bytes) 2004-08-09 23:22

- Relationships

-  Notes
(0004976)
user72
2004-08-10 01:32

Set a breakpoint on that line and when you reach it, check the value of HandleAllocated (Ctrl+F7, type "HandleAllocated", <ENTER>). What do you get?
(0004978)
anonymous (viewer)
2004-08-10 02:44

The HandleAllocated returns True.

When I change the property Tabstop into SaveActivePage.TabStop, then no error is returned and the bug is fixed.
(0004982)
user72
2004-08-10 06:31

> When I change the property Tabstop into
> SaveActivePage.TabStop, then no error is returned and the bug is fixed.
But that is not the same. The code is trying to disable tabbing into the page control (and thus disable tabbing into the child tabs). Your change disables tabbing into the active tab only.

FWIW, I am not able to duplicate the error using W2k.

Are you setting HideAllTabs somewhere in code? Where (in what event/context)?
(0004986)
Reino (reporter)
2004-08-11 00:02

No other events added, only a OnShow and a OnHide with no special things. The HideAllTabs is only set in the Properties. When I build a sample application that uses the pagecontrol, there is no error.
Only in the full application I get this error. (uses infopower components)
(0004987)
user72
2004-08-11 01:16

> Only in the full application I get this error. (uses infopower components)
So, this error could be related to the component(s) on the tabs? If you remove the Infopower stuff, do you still get the error?
(0005020)
Reino (reporter)
2004-08-19 02:25

I removed all the components, no success (also in the uses list). The error stays as I change the property HideallTabs > True, otherwise no errors. I think that one of the many used components triggered the error, but finding that component is a major task (I think) When I create a new application no errors. So when I have lots of time I start a search to find the component.
(0005027)
user72
2004-08-19 23:57

As a temporary solution, set HideAllTabs := true at run-time (for example, in the OnCreate event of the form). As I am unable to duplicate the error, I cannot debug it either.
(0005251)
user72
2004-09-23 06:26

I've committed the proposed change but as I am unable to dupliacte the error, I am not sure this actually fixes anything.
(0005318)
user72
2004-10-05 11:28

Since there is no reply, I am assuming this now works

- Issue History
Date Modified Username Field Change
2004-08-09 23:22 Reino New Issue
2004-08-09 23:22 Reino File Added: JvComCtrls.pas
2004-08-09 23:23 Reino Issue Monitored: Reino
2004-08-10 01:32 user72 Note Added: 0004976
2004-08-10 02:44 anonymous Note Added: 0004978
2004-08-10 06:31 user72 Note Added: 0004982
2004-08-11 00:02 Reino Note Added: 0004986
2004-08-11 01:16 user72 Note Added: 0004987
2004-08-19 02:25 Reino Note Added: 0005020
2004-08-19 23:57 user72 Note Added: 0005027
2004-09-23 06:26 user72 Note Added: 0005251
2004-09-23 06:26 user72 Status new => feedback
2004-09-25 02:05 user72 Issue Monitored: user72
2004-10-05 11:28 user72 Status feedback => resolved
2004-10-05 11:28 user72 Resolution open => fixed
2004-10-05 11:28 user72 Assigned To => user72
2004-10-05 11:28 user72 Note Added: 0005318


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker