Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002208 [JEDI VCL] 02 Installation minor always 2004-10-12 09:00 2004-10-16 13:21
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002208: Package order in package groups
Description Both in 'C5 Packages.bpg' and 'C6 Packages.bpg' (may be in all group)
the package order
           JvStdCtrlsC5R.bpl JvStdCtrlsC5D.bpl \
           JvCtrlsC5R.bpl JvCtrlsC5D.bpl \
should be
           JvStdCtrlsC5R.bpl JvCtrlsC5R.bpl \
           JvStdCtrlsC5D.bpl JvCtrlsC5D.bpl \
because JvStdCtrlsC5D.bpl depends on JvCtrlsC5R.bpl
and one run build is impossible this way
Additional Information
Tags No tags attached.
Attached Files zip file icon packages.zip [^] (3,331 bytes) 2004-10-12 10:03
zip file icon packages_good.zip [^] (1,677 bytes) 2004-10-15 20:54

- Relationships

-  Notes
(0005359)
anonymous (viewer)
2004-10-12 09:13
edited on: 2004-10-12 10:04

Also would be a god idea to make separate package groups
for Runtime and design time packages
That would make build of the package groups in the ide much more easier.
(uploaded file packages.zip contains c5 and c6 modified separated project group files)

edited on: 10-12-04 10:04
(0005400)
ihof (reporter)
2004-10-15 20:56

sorry the c6 packages had errors, i've resent them in the second (packages_good.zip) file. sorry once again.
(0005405)
obones (administrator)
2004-10-16 13:21

The order of packages has been corrected in CVS.
As to create two package groups, this is not an option. By the way, compiling the packages in the IDE is NOT RECOMMENDED because of numerous bugs in the package group manager. Please either use the installer or the command line builder (in packages\bin).

- Issue History
Date Modified Username Field Change
2004-10-12 09:00 anonymous New Issue
2004-10-12 09:13 anonymous Note Added: 0005359
2004-10-12 10:03 anonymous File Added: packages.zip
2004-10-12 10:04 anonymous Note Edited: 0005359
2004-10-15 20:54 ihof File Added: packages_good.zip
2004-10-15 20:56 ihof Note Added: 0005400
2004-10-15 21:09 ihof Issue Monitored: ihof
2004-10-16 08:14 obones Status new => assigned
2004-10-16 08:14 obones Assigned To => obones
2004-10-16 13:21 obones Status assigned => resolved
2004-10-16 13:21 obones Resolution open => fixed
2004-10-16 13:21 obones Note Added: 0005405


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker