Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002272 [JEDI VCL] 00 JVCL Components major always 2004-10-28 01:31 2005-04-12 09:14
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002272: TJvOutlookbar & XP Theme and Color: 14985086
Description I´ve Delphi 6 Pro ( Both SPs ). I set up a new Application with the TJvOutlookbar and set the color (14985086) in the property of TJvOutlookbar. Now with Win2000 it´s all correct but with WinXP and the Default XP Theme the Color is Black. I´ve compiled the JVCL with XP Theme support.

Best regards

Rainer
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005522)
user72
2004-10-29 01:37
edited on: 2004-10-30 05:10

Set a breakpoint in JvOutlookBar.TJvCustomOutlookBar.DrawCurrentPage on the Canvas.FillRect call and check that it is executed on XP.

...
        {$IFDEF JVCLThemesEnabled}
        if not ThemedBackground or not ThemeServices.ThemesEnabled then
        {$ENDIF JVCLThemesEnabled}
          Canvas.FillRect(R); // set breakpoint here and see if it executes on XP
...

edited on: 10-30-04 05:10
(0005683)
anonymous (viewer)
2004-11-20 18:10

Hi,

i´ve set the breakpoint like your note but "Canvas.FillRect(R);" where never executed. "ThemedBackground" and ThemeServices.ThemesEnabled are both "True".

Whats wrong?

Best regards

Rainer
(0005684)
user72
2004-11-21 12:28

Is JVCLThemesEnabled defined (i.e is the line "if not ThemedBackground ..." executed)?
(0005778)
obones (administrator)
2004-11-30 04:41

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 14 days, we will consider this issue closed.
(0006976)
obones (administrator)
2005-04-12 09:14

This is considered resolved

- Issue History
Date Modified Username Field Change
2004-10-28 01:31 anonymous New Issue
2004-10-29 01:37 user72 Note Added: 0005522
2004-10-29 01:37 user72 Status new => feedback
2004-10-30 05:10 user72 Note Edited: 0005522
2004-11-20 18:10 anonymous Note Added: 0005683
2004-11-21 12:28 user72 Note Added: 0005684
2004-11-30 04:41 obones Note Added: 0005778
2005-04-12 09:14 obones Status feedback => resolved
2005-04-12 09:14 obones Resolution open => fixed
2005-04-12 09:14 obones Assigned To => obones
2005-04-12 09:14 obones Note Added: 0006976


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker