Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002354 [JEDI VCL] 00 JVCL Components minor always 2004-12-02 01:27 2004-12-18 06:53
Reporter anonymous View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002354: Installation failed
Description When I try to install the latest JVCL I get the following error/log.

Windows XP Service Pack 2 (5.1.2600)

"C:\Program Files\Borland\Delphi7\Bin\make.exe" -l+ -f Makefile.mak Templates
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
Fatal: Command arguments too long
Additional Information
Tags No tags attached.
Attached Files txt file icon Output from Install batch file.txt [^] (15,081 bytes) 2004-12-04 00:25

- Relationships

-  Notes
(0005812)
AHUser (developer)
2004-12-02 15:40
edited on: 2004-12-02 15:40

This is a known bug, but it is something we cannot really fix because it is the make.exe which has the problem.
Maybe someone wants to write a new Borland compatible make.exe

(0005813)
anonymous (viewer)
2004-12-02 21:48

The strange thing is that I copied the vcl dir. and installed it at home without any problems. I did however notice that with the installation at work (the installation which gave these problems) there were several messages in the execution of the batchfile. Something about several units not being declared. (ex. types, windows) I looked into the macros that were generated and added the types unit in a few units. They then seemed to be generated just fine. Is there any relation with these errors and the one I first described? I did not modify them all, because I was not sure if this had anything to do with my installation problem and at home the same installtion worked just fine (without the manipulation of units).

If this is indeed a problem with the make version, is there a workaround?

PS: I have both D7 and D2005 installed.
(0005814)
anonymous (viewer)
2004-12-02 21:55

I forgot to mention, that I checked the make versions of my home and work installations and they are identical. I use the same combination of programs at home and at work. D7 + D2005.
(0005819)
AHUser (developer)
2004-12-03 03:41

After installing the D2k Trial version I got the "command line too long" error, too. But by calling the installer with this:
----------
SET PATH=C:\Borland\Delphi7\Bin
install
----------
The problem disappeard. I think it has something todo with the environment variables. But some reported that this had not worked on their computers. So it is a mystery.
(0005820)
anonymous (viewer)
2004-12-03 04:17

I already tried to set the path in the enviromentsettings. But that didn't help either. But I will try it the way you suggested and let you know.
(0005821)
anonymous (viewer)
2004-12-03 04:27

The suggested possible solution didn't work. I will try to find out where the problem lies and let you know. I will compare my home installation with the one at work. Hopefully I will find something, I will let you know if I do.
(0005824)
mattis000102 (reporter)
2004-12-04 00:24

Get the same error, Delphi 7 and 2005 installed. Error came after installing Delphi 2005. Tried all the suggested things with changing the enviroment variables and running the installer with SET PATH. I also see the errors during the execution of the install batch file. Will try to see if uninstalling Delphi 2005 will help.
(0005825)
mattis000102 (reporter)
2004-12-04 00:26

Uploaded a text file with the output from install.bat just incase this gives someone a bright idea.
(0005826)
anonymous (viewer)
2004-12-04 01:04

Uninstalled Delphi 2005 and now the installer works fine. Let me know if there is something that you need to get tested or if there is any other way that I can help out, otherwise I wont reinstall Delphi 2005 at the moment, since it was just for fun and I need D7 to be working.
(0005827)
anonymous (viewer)
2004-12-04 02:38

At this moment I need both versions. Some packages from other products are not yet compatible with D2005. When they are I won't be needing the D7 version. However for the time being, I will need to find a other solution. As I already stated before, I have both versions installed at home and at work, bur for some reason the version at work gives this error (just my luck). Anyway, thank you for your offer, but it looks like I will have to keep on searching for the problem.
(0005829)
AHUser (developer)
2004-12-04 06:13

> Uploaded a text file with the output from install.bat just incase this
> gives someone a bright idea.

This is not error this is due to the fact that Delphi 2005 supports inline functions.
It should be easy to eliminate the hints. Unfortunatelly does no Types unit exists for Delphi 5 which means another IFDEF.
(0005833)
anonymous (viewer)
2004-12-06 05:43

I have tried to find out where the problems lies. But the only thing I noticed, is that the d9 compiler is used instead of the d7 compiler when I try to install the D7 version. So maybe it is a problem of paths being set as mentioned earlier?
(0005835)
AHUser (developer)
2004-12-06 11:06

The build.exe which starts the compilation of the Installer uses the newest installed compiler. If you do not want it to do this you must open the install.bat and replace the "newest" by e.g. "d7"
(0005838)
anonymous (viewer)
2004-12-06 23:03

Great, it works! I modified the install.bat. I changed "newest" to d7 and it worked. Thank you for your help.
(0005869)
AHUser (developer)
2004-12-11 07:33

I have changed build.exe and the Installer and this change should fix all "command line too long" issues.

Can someone confirm this. (maybe you must wait until the new installer is available in anonymous CVS)
(0005908)
anonymous (viewer)
2004-12-17 16:11

sadfasd
(0005918)
AHUser (developer)
2004-12-18 06:53

Fixed by updated build system

- Issue History
Date Modified Username Field Change
2004-12-02 01:27 anonymous New Issue
2004-12-02 11:20 jpsc Issue Monitored: jpsc
2004-12-02 15:40 AHUser Note Added: 0005812
2004-12-02 15:40 AHUser Note Edited: 0005812
2004-12-02 21:48 anonymous Note Added: 0005813
2004-12-02 21:55 anonymous Note Added: 0005814
2004-12-03 03:41 AHUser Note Added: 0005819
2004-12-03 04:17 anonymous Note Added: 0005820
2004-12-03 04:27 anonymous Note Added: 0005821
2004-12-04 00:24 mattis000102 Note Added: 0005824
2004-12-04 00:25 mattis000102 File Added: Output from Install batch file.txt
2004-12-04 00:26 mattis000102 Note Added: 0005825
2004-12-04 01:04 anonymous Note Added: 0005826
2004-12-04 02:38 anonymous Note Added: 0005827
2004-12-04 06:13 AHUser Note Added: 0005829
2004-12-06 05:43 anonymous Note Added: 0005833
2004-12-06 11:06 AHUser Note Added: 0005835
2004-12-06 23:03 anonymous Note Added: 0005838
2004-12-11 07:33 AHUser Note Added: 0005869
2004-12-11 08:13 AHUser Status new => feedback
2004-12-17 16:11 anonymous Note Added: 0005908
2004-12-18 06:53 AHUser Status feedback => resolved
2004-12-18 06:53 AHUser Resolution open => fixed
2004-12-18 06:53 AHUser Assigned To => AHUser
2004-12-18 06:53 AHUser Note Added: 0005918
2004-12-18 06:53 AHUser Assigned To AHUser =>
2004-12-18 17:05 jpsc Issue End Monitor: jpsc


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker