Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002392 [JEDI VCL] 00 JVCL Components minor always 2004-12-17 00:03 2004-12-22 08:16
Reporter anonymous View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002392: Error installing
Description I am still having a problem installing the latest JVCL for D7. A Windows exception occurs when the installationprogram tries to compile the JvCoreD7D package).Doe s anyone else have this problem? If I install the same version for D2005 everthing is ok.
Additional Information
Tags No tags attached.
Attached Files jpg file icon error.jpg [^] (16,276 bytes) 2004-12-20 03:06
txt file icon Error_Log.txt [^] (2,371 bytes) 2004-12-20 06:36
jpg file icon Error02.JPG [^] (18,650 bytes) 2004-12-20 06:40
jpg file icon Error03.JPG [^] (18,791 bytes) 2004-12-20 06:40

- Relationships
has duplicate 0002390closed Error Installing latest JVCL 

-  Notes
(0005900)
anonymous (viewer)
2004-12-17 01:53

I have same problem of Error Installing! Have Delphi 7 PRO w/ JEDI 2.1, and install to upgrade, and get this message:
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
(...)
[Generating: Packages]
Generating packages for D7
    Loaded template.dof
    Loaded template.dpk
    Loaded template.res
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Compiling: Packages]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
Fatal: '"C:\Programas\Borland\Delphi7\Projects\Bpl"\DJclVcl.dcp' does not exist - don't know how to make it
** error 1 ** deleting CompilePackages
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
(0005901)
anonymous (viewer)
2004-12-17 02:51

I have download Latest (JVCL3 - 2004-12-17 00:37:41), install for Delphi 7 and get this error:
---------------------------
...
[Compiling: Packages]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Compiling: Jv3rdD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
4842 lines, 0.12 seconds, 26972 bytes code, 117 bytes data.
Fatal: '"C:\Program Files\Borland\Delphi7\Projects\Bpl"\DJclVcl.dcp' does not exist - don't know how to make it

** error 1 ** deleting CompilePackages
---------------------------------
(0005902)
AHUser (developer)
2004-12-17 03:18

I can only guess because I cannot reproduce this.

Have you updated the JCL, too? JVCL depends heavily on the JCL and small changes
in the JCL have large impact on the JVCL. The JVCL Installer is no JCL Installer so you must install the JCL with the JCL Installer before starting the JVCL Installer.
(0005904)
anonymous (viewer)
2004-12-17 03:38

Hi AHUser,

Where I download JCL Installer? Look in http://sourceforge.net/project/showfiles.php?group_id=45786 [^]
and can't find JCL Install!!
(0005906)
anonymous (viewer)
2004-12-17 08:28

I have the latest JCL and JVCL files. But I can't install Jcl because the installer doesn't work. So I installed the packages instead that seemed to go fine. I did this for both the D7 and D2005 versions. After that I tried to install the JCL, the D2005 version installed ok, but the D7 version just crashed on the DCC32 when trying to compile JvCoreD7D. At this moment both installers (JCL and JVCL) crash and burn on my system. This problem started at the same time that the compiler became visible in the installer of JVCL. I however am not saying this causes the problem.
(0005916)
AHUser (developer)
2004-12-18 05:25

You could open the JVCL Installer with Delphi 2005 and setup the parameters to "--ignore-ide". Start the compile and start installer and install the JVCL for Delphi 7. If the fault is raised by the Installer you should be able to find the execption raising code line.
(0005936)
anonymous (viewer)
2004-12-19 23:38

I tried what you suggested. But the same thing happens in the IDE. The installationprogram crashes on the compilation of the package JvCoreD7D. Windows also creates a dumpfile.
(0005937)
anonymous (viewer)
2004-12-20 03:06

I added a jpg of the error.
(0005941)
AHUser (developer)
2004-12-20 03:59

This screenshot does not say anything valuable. The log ("Details >>") should be more informative. And the error message would be of interest, too.
(0005956)
anonymous (viewer)
2004-12-20 06:43

Some text in the windows is in dutch. Do you also need the dump from windows?
(0005980)
anonymous (viewer)
2004-12-22 05:04

Some more info:

I downloaded the latest version of JVCL and installed it as I do normally, again it stopped at the same point as before. But now I tried a clean install for the D7 version. I first modified the install.bat (changed newest --> d7) and then installed again. This time it installed without any problems. Could it be possible the the problem is created by the fact that the installer and other files are compiled with the d9 compiler? I think that the only thing I changed since this problems occured was the sequence in which I installed the D2005 version and d7 version. Don't know if this helps.
(0005984)
anonymous (viewer)
2004-12-22 07:24

Hi,
I'm the user ID 0005901 and 0005904.

I install de last JCL (v1.93) and next de JVCL 3.0 Beta 2, all work's fine. Install without problems.

Only problem is some components no more is in use! like TJvBlinkingLabel, and other's! :( the rest is fine.

Thanks AHUser for JCL tip.

Regards,
LuBoc
(0005985)
AHUser (developer)
2004-12-22 08:16

TJvBlinkingLabel is now part of TJvBehaviourLabel.

- Issue History
Date Modified Username Field Change
2004-12-17 00:03 anonymous New Issue
2004-12-17 01:53 anonymous Note Added: 0005900
2004-12-17 02:51 anonymous Note Added: 0005901
2004-12-17 03:18 AHUser Note Added: 0005902
2004-12-17 03:38 anonymous Note Added: 0005904
2004-12-17 08:28 anonymous Note Added: 0005906
2004-12-18 05:25 AHUser Note Added: 0005916
2004-12-18 06:54 AHUser Relationship added has duplicate 0002390
2004-12-18 06:57 AHUser Assigned To => AHUser
2004-12-18 06:57 AHUser Status new => feedback
2004-12-19 23:38 anonymous Note Added: 0005936
2004-12-20 03:06 anonymous File Added: error.jpg
2004-12-20 03:06 anonymous Note Added: 0005937
2004-12-20 03:59 AHUser Note Added: 0005941
2004-12-20 06:36 anonymous File Added: Error_Log.txt
2004-12-20 06:40 anonymous File Added: Error02.JPG
2004-12-20 06:40 anonymous File Added: Error03.JPG
2004-12-20 06:43 anonymous Note Added: 0005956
2004-12-22 05:04 anonymous Note Added: 0005980
2004-12-22 07:24 anonymous Note Added: 0005984
2004-12-22 08:16 AHUser Status feedback => resolved
2004-12-22 08:16 AHUser Resolution open => fixed
2004-12-22 08:16 AHUser Note Added: 0005985


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker