Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002447 [JEDI VCL] 00 JVCL Components trivial always 2004-12-29 12:22 2005-02-15 17:43
Reporter Arioch View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002447: Defaults for TJvAppRegistryStorage
Description Just dropped TJvAppRegistryStorage onto form (and FormStorage).

After i run the application, got such a key in my registry:
  HKEY_CURRENT_USER\Form1

Then i toggled (in Desing time !!!) .UseOldDefaultRoot.
And now i have the key HKEY_CURRENT_USER\HKEY_LOCAL_MACHINE

Brrr....

I think, that when we 1st drop some AppStorage, it should create some temporary name, from ProjectOptions/Title. Maybe even add some timestamp to avoid numerous trivial names suddenly the same (like Project1 :-) ), and let default company would be something like 'Some JediVCL using application'

And!!! those keys SHOULD be under HK**\Software by default!
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006057)
jfudickar (developer)
2005-01-02 07:12

I can't reproduce this. If i add a TJvAppRegistryStorage and then change UseOldDefaultRoot then i get "Software\%COMPANY_NAME%\%APPL_NAME%". And this is the designed behaviour.

For me this could be closed
(0006060)
Arioch (developer)
2005-01-02 09:15

Did You drop FormStorage as well ?

What registry keys are created in then ?
When You runned the app ?

What is Your Delphi ? mine is 5.
(0006075)
jfudickar (developer)
2005-01-04 05:01

HI Arioch,

please have a look at the new implementation.

Greetings
Jens
(0006396)
obones (administrator)
2005-02-04 04:09

Please note that without any feedback in the next 7 days, we will consider this issue resolved.
(0006407)
anonymous (viewer)
2005-02-04 05:58

up to you guys.
Maybe before jvcl 3.1
now just out of time myself :-(
(0006504)
jfudickar (developer)
2005-02-15 17:43

No further comments -> fixed

- Issue History
Date Modified Username Field Change
2004-12-29 12:22 Arioch New Issue
2005-01-01 08:52 obones Status new => assigned
2005-01-01 08:52 obones Assigned To => obones
2005-01-02 07:12 jfudickar Note Added: 0006057
2005-01-02 07:12 jfudickar Issue Monitored: jfudickar
2005-01-02 09:15 Arioch Note Added: 0006060
2005-01-04 05:01 jfudickar Note Added: 0006075
2005-01-05 02:58 jfudickar Assigned To obones => jfudickar
2005-01-05 02:59 jfudickar Status assigned => feedback
2005-02-04 04:09 obones Note Added: 0006396
2005-02-04 05:58 anonymous Note Added: 0006407
2005-02-15 17:43 jfudickar Status feedback => resolved
2005-02-15 17:43 jfudickar Resolution open => fixed
2005-02-15 17:43 jfudickar Note Added: 0006504


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker