Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002521 [JEDI VCL] 00 JVCL Components minor always 2005-01-17 13:01 2006-03-30 02:51
Reporter carlosw View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002521: TJvDBHTLabel doesn't use the DisplayFormat property to display a field
Description TJvDBHTLabel doesn't use the DisplayFormat property assigned to a TField to display it's value.
Additional Information function ReplaceFieldNameTag(Str: string; DataSet: TDataSet): string;
...
...
    if Assigned(DataSet) and DataSet.Active then
    begin
      F := DataSet.FindField(FieldName);
      if F <> nil then
        Text := F.AsString <<<==== THIS SHOULD BE F.DisplayText
      else
        Text := Format('(%s)',[FieldName]);
    end

F.AsString => doesn't use DisplayFormat
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006299)
carlosw (reporter)
2005-01-27 13:26

anyone?

The problem is when i set a DisplayMask for a field the control doesn't use my DisplayMask to display the field.

e.g.
TFloatField.DisplayFormat = '##,###,#0.00'

TFloatField.AsString: the displaymask is not used
TFloatField.DisplayText: the displaymask is used
(0008735)
obones (administrator)
2006-03-30 02:51

This is already fixed in CVS.

- Issue History
Date Modified Username Field Change
2005-01-17 13:01 carlosw New Issue
2005-01-27 13:26 carlosw Note Added: 0006299
2006-03-30 02:51 obones Status new => resolved
2006-03-30 02:51 obones Resolution open => fixed
2006-03-30 02:51 obones Assigned To => obones
2006-03-30 02:51 obones Note Added: 0008735


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker