Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002617 [JEDI VCL] 00 JVCL Components major always 2005-02-10 03:11 2005-02-11 03:10
Reporter anonymous View Status public  
Assigned To robert_marquardt
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002617: Memory Leak in Constructor of TJvgListBox
Description In the constructor the private FWallpaper is created two times:
Line 225 is correct, in line 237 the FWallPaper is assigned to a new Bitmap Object. So the component produce a memory leak, because the the pointer of the bitmap-object from line 225 get lost and the memory of the object is still allocated, but without any refrence.

<JvgListBox.pos>
...
On Line 225: FWallpaper := TBitmap.Create;
...
On Line 237: FWallpaper := TBitmap.Create;
...
Additional Information Version 3.00

Best Regards
Mario Rasser

In case of questions
contact: m.rasser@deltaz.com
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006447)
anonymous (viewer)
2005-02-10 03:13

Sorry Line 236 produces the leak.(mra)
(0006452)
robert_marquardt (developer)
2005-02-11 03:10

Fixed as proposed (deleted second Create).

- Issue History
Date Modified Username Field Change
2005-02-10 03:11 anonymous New Issue
2005-02-10 03:13 anonymous Note Added: 0006447
2005-02-11 03:09 robert_marquardt Status new => assigned
2005-02-11 03:09 robert_marquardt Assigned To => robert_marquardt
2005-02-11 03:10 robert_marquardt Status assigned => resolved
2005-02-11 03:10 robert_marquardt Resolution open => fixed
2005-02-11 03:10 robert_marquardt Note Added: 0006452


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker