Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002695 [JEDI VCL] 00 JVCL Components minor always 2005-02-27 23:45 2005-03-13 06:43
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002695: JvExpressButton not storing font information
Description I created a new D6 Enterprise application. I added a JvExpress to the main form and then a couple of JvExpressButtons to the JvExpress. I set the JvExpress to use the Parent Font (Trebuchet MS). I set the JvExpressButton to use the Parent Font as well.

Then I save the application, close all and reload the application. The JvExpressButton Parent Font value is False and the font colour has revered back to the default of clWhite (can we change that to clWindowText?).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006634)
user72
2005-03-03 00:59

Try this:

Add to/change in class

property ParentFont default false;

Add in constructor:

...
  ParentFont := false;
  Font.Color := clHighlightText;
...

Rebuild the RT package (JvCustomD?R.dpk)
(0006643)
anonymous (viewer)
2005-03-06 00:13

That appears to have done the trick.

I switched things up a bit:

1) I changed the default to True
2) In the constructor I set ParentFont := True;
3) I set Font.Color := clWindowText;

It seemed like a TButton was setting the ParentFont to true and the color to clWindowText so that's why I made those adjustments.

Thanks for your help.

Django
(0006658)
user72
2005-03-09 01:01

Your changes restore the default behavior and you could have accomplished the same thing it by just removing the line that changes the Font properties :)

Anyway, the Expressbuttons should have a default white color since they are generally placed on a JvExpress that has a dark gray background, so the changes I posted are the ones I am going to commit to CVS.
(0006674)
anonymous (viewer)
2005-03-10 09:06

I'll arm wrestle you for which colour they should start out as. :-)

Thanks.

Django
(0006675)
user72
2005-03-10 12:44

I have very big arms ;)
(0006693)
user72
2005-03-13 06:43

Fixed in CVS

- Issue History
Date Modified Username Field Change
2005-02-27 23:45 anonymous New Issue
2005-03-03 00:59 user72 Note Added: 0006634
2005-03-03 00:59 user72 Status new => feedback
2005-03-06 00:13 anonymous Note Added: 0006643
2005-03-09 01:01 user72 Note Added: 0006658
2005-03-10 09:06 anonymous Note Added: 0006674
2005-03-10 12:44 user72 Note Added: 0006675
2005-03-13 06:43 user72 Status feedback => resolved
2005-03-13 06:43 user72 Resolution open => fixed
2005-03-13 06:43 user72 Assigned To => user72
2005-03-13 06:43 user72 Note Added: 0006693


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker