Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002716 [JEDI VCL] 00 JVCL Components minor always 2005-03-05 16:42 2005-04-12 05:40
Reporter boerema1 View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002716: JvHTListBox: all items get painted with selected color after selecting an item with the mouse
Description In JvHTListBox after selecting an item with the mouse all items get painted with FColorHighlight as background color when you move the mouse over these items.

To fix this I suggest the followng fix in procedure TJvCustomHTListBox.MouseMove(Shift: TShiftState; X, Y: Integer);

...

  if Self.Selected[I] then
  begin
    State := [odSelected];
    Canvas.Font.Color := FColorHighlightText;
    Canvas.Brush.Color := FColorHighlight; // Added
  end
  else
  begin // Added
    Canvas.Font.Color := Font.Color;
    Canvas.Brush.Color := Color; // Added
  end; // Added
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0002821resolvedobones TJvHTListBox MouseMove leaves wrong color 

-  Notes
(0006942)
obones (administrator)
2005-04-12 05:40

Thanks, this is now in CVS.

- Issue History
Date Modified Username Field Change
2005-03-05 16:42 boerema1 New Issue
2005-04-12 05:40 obones Status new => resolved
2005-04-12 05:40 obones Resolution open => fixed
2005-04-12 05:40 obones Assigned To => obones
2005-04-12 05:40 obones Note Added: 0006942
2005-04-12 06:20 obones Relationship added duplicate of 0002821


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker