Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002840 [JEDI VCL] 02 Installation block always 2005-04-05 16:39 2005-04-08 23:40
Reporter Brent Rose View Status public  
Assigned To outchy
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002840: Proc entry point not located in DJcl50.bpl
Description Installing JCL195 into D5 seems to work OK, but cannot load pkgs in Delphi

"Delphi5:delphi32.exe - Entry Point Not Found"

"The procedure entry point @Jclfileutils@initialization$qqrv could not be located in the dynamic link library DJcl50.bpl"

Fresh install of D5 on Win2k. D7 present (JCL installs OK there). Same install on XPPro machine (to D5 & D7) works OK.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006854)
outchy (administrator)
2005-04-06 14:07
edited on: 2005-04-06 14:20

It seems to be a problem with JCL design-time packages (IE: IdeOpenDlgFavoriteD50, JclDebugIDED50 or ProjectAnayserD50) and JVCL design-tume packages.
You should compile these packages too.

(0006865)
Brent Rose (reporter)
2005-04-07 13:27

OK - JCL design packages as listed each compile OK, but raise the same error when try to install. DJcl50.bpl re-compiles OK, but makes no difference.

Have also fully removed D5 & D7 and re-installed D5 only on this PC.
(0006867)
outchy (administrator)
2005-04-08 05:22

An other explanation would be the existance of an old version of DJcl50.bpl in one of your search path (c:\winnt, c:\winnt\system32 or other ones - see you PATH environment variable). These files may be redistribued with 3rd-party-programs made with D5 using jcl in runtime packages.
(0006874)
Brent Rose (reporter)
2005-04-08 19:41

Thanks! That was the problem - an ancient version was lurking somewhere.

- Issue History
Date Modified Username Field Change
2005-04-05 16:39 Brent Rose New Issue
2005-04-05 16:40 Brent Rose Issue Monitored: Brent Rose
2005-04-06 14:07 outchy Note Added: 0006854
2005-04-06 14:20 outchy Note Edited: 0006854
2005-04-07 13:27 Brent Rose Note Added: 0006865
2005-04-08 05:22 outchy Note Added: 0006867
2005-04-08 19:41 Brent Rose Note Added: 0006874
2005-04-08 19:48 Brent Rose Issue End Monitor: Brent Rose
2005-04-08 23:40 outchy Status new => resolved
2005-04-08 23:40 outchy Resolution open => fixed
2005-04-08 23:40 outchy Assigned To => outchy


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker