Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002848 [JEDI VCL] 00 JVCL Components minor always 2005-04-08 03:58 2006-01-05 08:15
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002848: TJvImagesViewer ScrollBars Repaint
Description Scrollbars of this component does not come redesigned until I don't click over. Inserting this component in a tabsheet and selecting between a tabsheet and an other the scrollbars remain dirty. Moreover is sufficient to move the window of an other program over to these scrollbars in order rendering them completely dirty.
Additional Information
Tags No tags attached.
Attached Files zip file icon Project1.zip [^] (1,768 bytes) 2005-04-08 07:24

- Relationships

-  Notes
(0006869)
outchy (administrator)
2005-04-08 07:26
edited on: 2005-04-08 07:27

Hello,

I tested your program according to your description but I cannot reproduce the bug. My testing environment is Windows 2000 Pro/D7 Pro/JVCL CVS/JCL CVS.

Please give us more informations about your environment (operating system, version of the JVCL, version of the JCL, version of Delphi).

Thanks

PS: I linked a file containing the sample project (you just have to change the directory to a location containing a lot of images).

(0006890)
anonymous (viewer)
2005-04-11 01:59

I've found the cause: XPManifest.

With Delphi 7, add this component from Win32 palette to Project1 and run it; with or without thumbnails, the scrollbar remain dirty until you clic on it.
(0007199)
obones (administrator)
2005-05-18 06:33

Can anyone have a look at this issue?
Take into account the last note from the original poster.
(0007722)
obones (administrator)
2005-08-09 06:58

Anyone ?
(0007734)
outchy (administrator)
2005-08-09 07:14

Unfortunatly, I don't have any copy of Windows XP so using a manifest on my system doesn't show me the problem.
(0007747)
obones (administrator)
2005-08-09 07:37

I just tried, I could not duplicate it.
(0008092)
anonymous (viewer)
2005-11-16 07:52

I have exactly the same problem with Delphi 2005 and the latest version of Jedi VCL. I verified the problem in several pc with Windows XP (Home and Professional).
(0008112)
AHUser (developer)
2005-11-22 04:35

I cannot reproduce this with Delphi 2005, WinXP SP, with and without the TXPManifest.
(0008295)
obones (administrator)
2006-01-05 08:15

No answers in more than 14 days, this is believed to be fixed

- Issue History
Date Modified Username Field Change
2005-04-08 03:58 anonymous New Issue
2005-04-08 07:24 outchy File Added: Project1.zip
2005-04-08 07:26 outchy Note Added: 0006869
2005-04-08 07:27 outchy Note Edited: 0006869
2005-04-11 01:59 anonymous Note Added: 0006890
2005-05-18 06:33 obones Note Added: 0007199
2005-05-18 06:33 obones Status new => feedback
2005-08-09 06:58 obones Note Added: 0007722
2005-08-09 07:14 outchy Note Added: 0007734
2005-08-09 07:37 obones Status feedback => resolved
2005-08-09 07:37 obones Resolution open => unable to reproduce
2005-08-09 07:37 obones Assigned To => obones
2005-08-09 07:37 obones Note Added: 0007747
2005-11-16 07:52 anonymous Status resolved => feedback
2005-11-16 07:52 anonymous Resolution unable to reproduce => reopened
2005-11-16 07:52 anonymous Note Added: 0008092
2005-11-22 04:35 AHUser Note Added: 0008112
2006-01-05 08:15 obones Status feedback => resolved
2006-01-05 08:15 obones Resolution reopened => fixed
2006-01-05 08:15 obones Note Added: 0008295


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker