Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002871 [JEDI VCL] 00 JVCL Components minor always 2005-04-13 12:17 2005-04-23 01:19
Reporter anonymous View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002871: TJvCustomGraphicButton.Click calls inherited in the wrong order
Description TJvCustomGraphicButton.Click currently calls "inherited Click" at the top of the procedure. I think it should be at the bottom.

Rationale: This procedure mainly changes the state of the button's Down flag, while the inherited procedure mainly calls any registered OnClick handlers. It's more usual to expect that an OnXX event is called *after* the class has provided default behavior than vice versa. In this particular case, it's natural to implement an OnClick handler that sets the Down property itself according to app-specific logic; you can't do that, though, because TJvCustomGraphicButton.Click will then reverse the state of the down property afterwards.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007000)
teejaydub (reporter)
2005-04-13 12:21

Sorry, didn't think to make an account first. I'm the reporter.
(0007052)
AHUser (developer)
2005-04-23 01:19

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2005-04-13 12:17 anonymous New Issue
2005-04-13 12:21 teejaydub Note Added: 0007000
2005-04-13 12:21 teejaydub Issue Monitored: teejaydub
2005-04-23 01:18 AHUser Issue Monitored: AHUser
2005-04-23 01:18 AHUser Issue End Monitor: AHUser
2005-04-23 01:19 AHUser Status new => resolved
2005-04-23 01:19 AHUser Resolution open => fixed
2005-04-23 01:19 AHUser Assigned To => AHUser
2005-04-23 01:19 AHUser Note Added: 0007052


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker