Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002980 [JEDI VCL] 00 JVCL Components major always 2005-05-21 14:35 2005-08-28 09:49
Reporter Stewart81 View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002980: jvDock crashes with Mozilla ActiveX
Description When the browser window looses focus, then regains focus if you have docked windows it creates an access violation error as follows:

Access violation at address 75410900. Read of address 75410900.

I've reproduced the problem several times and confirmed that if you close the docked windows it fixes the problem.

I tested it with all of the docking styles and it was reproduced with all of them so I suspect the problem doesn't lie in the styles themselves.

I am currently using the latest CVS version of the docking component.

Hopefully you guys can figure it out. I'm at a bit of a loss. Thanks :)

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007310)
anonymous (viewer)
2005-05-23 09:51

It seems to be specificly a problem when there's docked forms such that tabs are used. As long as there are no tabs involved the problem isn't reproduced. Any thoughts on this?
(0007311)
anonymous (viewer)
2005-05-23 09:53

Take that back. If you click a docked window it causes an error. But only when mozilla is up. I'm honestly not sure if this one is the mozilla control or if it's jvdock. Thanks for any ideas :)
(0007312)
anonymous (viewer)
2005-05-23 10:07

Seem's to also apply to the IE ActiveX Control.
(0007313)
anonymous (viewer)
2005-05-23 11:10

Actually after some more testing I think it might actually be somehow related to having 2 totaly seperate forms in an MDI window. In my case I have an editor window, and a webbrowser window. They are 2 seperate forms. I tried putting in just a blank second form in the MDI window and got the same error.

However the odd thing is even if I load the browser window first it still causes the error. I have removed everything off it though so it's litterly just a blank form. Only has the most basic objects in it's uses, and no code whatsoever. Just a blank form. Is there maybe something that it needs to have that I don't have perhaps? Thanks in advance for any information :)
(0007314)
anonymous (viewer)
2005-05-23 11:12

Oh further information. It seems to be the actual focussing of the docked window. If I removed AutoFocus from the docking component it doesn't do it when I bring up the window but instead if I bring focus to the docked window. Very confusing problem. I'm making no headway.
(0007324)
remkobonte (developer)
2005-05-23 14:43

Please upload a program that shows the bug, or provide specific steps to reproduce the problem.
(0007328)
anonymous (viewer)
2005-05-24 00:08

I think I found the problem. I'll know more shortly but it seems to be related to having an AppIdle procedure. Any thoughts?
(0007880)
obones (administrator)
2005-08-28 09:49

No news, considering this to be fixed.

- Issue History
Date Modified Username Field Change
2005-05-21 14:35 Stewart81 New Issue
2005-05-23 09:51 anonymous Note Added: 0007310
2005-05-23 09:53 anonymous Note Added: 0007311
2005-05-23 10:07 anonymous Note Added: 0007312
2005-05-23 11:10 anonymous Note Added: 0007313
2005-05-23 11:12 anonymous Note Added: 0007314
2005-05-23 14:43 remkobonte Note Added: 0007324
2005-05-23 14:43 remkobonte Status new => feedback
2005-05-24 00:08 anonymous Note Added: 0007328
2005-08-28 09:49 obones Status feedback => resolved
2005-08-28 09:49 obones Resolution open => fixed
2005-08-28 09:49 obones Assigned To => obones
2005-08-28 09:49 obones Note Added: 0007880


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker