Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002987 [JEDI VCL] 00 JVCL Components crash always 2005-05-24 07:20 2005-05-24 13:32
Reporter anonymous View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002987: JvTabBar causes AV when closing last tab
Description Steps to reproduce:
1. Place a JvTabBar on the form
2. Add few tabs to it
3. Run
4. Use "Close" buttons to close tabs one by one
5. After closing last tab:
   Access violation at address 00420490 in module 'Project1.exe'. Read of address
   00000004.
Additional Information Call stack:
Unit |Class |Method |Line |
---------------------------------------------------------------
classes.pas |TCollectionItem|GetIndex |3666 |
classes.pas |TCollectionItem|GetIndex |3665 |
system.pas | |_CallDynaInst |8706 |
Controls.pas |TControl |DoMouseUp |4831 |
Controls.pas |TControl |DoMouseUp |4829 |
Controls.pas |TControl |WMLButtonUp |4843 |
Controls.pas |TControl |WndProc |4645 |
Controls.pas |TWinControl |HandleNeeded |7792 |
Controls.pas |TWinControl |GetHandle |7802 |
                 | |GetCapture | |
Controls.pas |TWinControl |IsControlMouseMsg |6287 |
Controls.pas |TControl |WndProc |4592 |
Controls.pas |TWinControl |WndProc |6342 |
Controls.pas |TWinControl |MainWndProc |6237 |
classes.pas | |StdWndProc |10966|
                 | |DispatchMessageA | |
                 | |DispatchMessageA | |
Forms.pas |TApplication |ProcessMessage |6873 |
Forms.pas |TApplication |ProcessMessage |6860 |
Forms.pas |TApplication |HandleMessage |6892 |
Forms.pas |TApplication |HandleMessage |6891 |
Forms.pas |TApplication |Run |6976 |
Forms.pas |TApplication |Run |6960 |
AllInOneLabel.dpr| | |61 |
Tags No tags attached.
Attached Files zip file icon JvTabBarCrash.zip [^] (10,956 bytes) 2005-05-24 07:38

- Relationships

-  Notes
(0007335)
AHUser (developer)
2005-05-24 07:29
edited on: 2005-05-24 07:30

I cannot reproduce this. Could you add a simple project that shows this behavior?

(0007336)
vlador (reporter)
2005-05-24 07:40

Sorry, my mistake. JvTabBar must be linked to JvPageList to reproduce crashing. I have uploaded sample project.
(0007341)
AHUser (developer)
2005-05-24 13:32

Keep in mind that it is up to you to remove the Pages from the PageList in the OnTabClosed event. The component will only select the "correct" page.

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2005-05-24 07:20 anonymous New Issue
2005-05-24 07:29 AHUser Note Added: 0007335
2005-05-24 07:29 AHUser Status new => feedback
2005-05-24 07:30 AHUser Note Edited: 0007335
2005-05-24 07:30 vlador Issue Monitored: vlador
2005-05-24 07:38 vlador File Added: JvTabBarCrash.zip
2005-05-24 07:40 vlador Note Added: 0007336
2005-05-24 13:32 AHUser Status feedback => resolved
2005-05-24 13:32 AHUser Resolution open => fixed
2005-05-24 13:32 AHUser Assigned To => AHUser
2005-05-24 13:32 AHUser Note Added: 0007341


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker