Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003000 [JEDI VCL] 00 JVCL Components minor always 2005-05-27 06:30 2005-06-11 02:40
Reporter obones View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0003000: TJvDatePickerEdit: Setting Checked to True before showing the component triggers ConvertError exception
Description I'm about to commit a change in TJvCustomDatePickerEdit.UpdateDisplay which adds this right after the initial test:

  // (obones): We need a valid handle here, because setting the text
  // will read the value of DateSeparator. This value is #0 until the
  // CreateWnd method is called.
  // If we don't do that, setting any property that changes the display
  // (like checked) just after having created the control at runtime
  // would trigger an "Invalid date" exception because the date, month
  // and day would not be separated at all.
  // Doing this means that a parent is required for the change to work.
  HandleNeeded;
Additional Information This is issue 3000 ;-)
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007419)
obones (administrator)
2005-06-11 02:40

This is now in CVS

- Issue History
Date Modified Username Field Change
2005-05-27 06:30 obones New Issue
2005-06-11 02:40 obones Status new => resolved
2005-06-11 02:40 obones Resolution open => fixed
2005-06-11 02:40 obones Assigned To => obones
2005-06-11 02:40 obones Note Added: 0007419


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker