Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003073 [JEDI VCL] 00 JVCL Components crash always 2005-07-03 21:21 2006-02-21 05:04
Reporter anonymous View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003073: memory leak in JvXPCheckBox
Description memory leaks when mouse passes over the JvXpCheckbox (about 4-12 bytes) or
when you check\uncheck it
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007525)
obones (administrator)
2005-07-04 13:22

Please provide a trace of this happening, I can't see anything wrong in the code at first look.
(0007526)
anonymous (viewer)
2005-07-05 03:00

try to place some XPcheckboxes on a clear form and run project
then look at the taskbar (project1.exe)
move mouse over XPcheckboxes (check and uncheck them)
look at the taskbar - project1.exe ocupies more and more memory
and when it ocupies about 30 Mb - project1.exe crash
(0007533)
waskol (reporter)
2005-07-06 19:04

hmmm... seems to me that a bitmap is never calls its free method...
(0007535)
waskol (reporter)
2005-07-07 04:12
edited on: 2005-07-07 04:13

Have a look at the report ID n° 0001488 that you can find here :
homepages.borland.com/jedi/issuetracker/view.php?id=1488


There seems to have some problem with BrushCopy... (palette leak on 8bit pixel format, and so on...) ...and another one with dormant bitmaps.

Here is what i suggest :
in JVXPCoreUtils.pas, find :
procedure JvXPColorizeBitmap(Bitmap: TBitmap; const AColor: TColor);

...and comment out all the calls to Dormant and FreeImage methods, like this :

procedure JvXPColorizeBitmap(Bitmap: TBitmap; const AColor: TColor);
var
  ColorMap: TBitmap;
  Rect: TRect;
begin
  Rect := Bounds(0, 0, Bitmap.Width, Bitmap.Height);
  ColorMap := TBitmap.Create;
  try
    ColorMap.Assign(Bitmap);
    //Bitmap.Dormant;
    {$IFDEF VCL}
    //Bitmap.FreeImage;
    {$ENDIF VCL}
    with ColorMap.Canvas do
    begin
      Brush.Color := AColor;
      BrushCopy({$IFDEF VisualCLX} ColorMap.Canvas, {$ENDIF} Rect, Bitmap, Rect, clBlack);
    end;
    {$IFDEF VisualCLX}
    Bitmap.FreeImage;
    Bitmap.Assign(ColorMap);
    Bitmap.TransparentMode := tmAuto;
    {$ENDIF VisualCLX}
    {$IFDEF VCL}
    //Bitmap.ReleaseHandle;
    Bitmap.Assign(ColorMap);
    //ColorMap.Dormant;
    //ColorMap.FreeImage;
    //ColorMap.ReleaseHandle;
    {$ENDIF VCL}
  finally
    ColorMap.Free;
  end;
end;

What is surprising is that the problem was supposed to be solved !

(0007544)
waskol (reporter)
2005-07-11 01:15

Please, could you consider issue solved and update changes to the CVS ? (not much work to do here ;) )

Thxs by advance.
(0007661)
François (reporter)
2005-08-04 09:41

The problem still exist !!!!
My test on Win 98
A form with some JvXPCheckBox, it crash very fast when i move mouse over XPcheckboxes.

I comment the line :
//Bitmap.Dormant;
//Bitmap.FreeImage;
...



any other suggestions ?
(0008585)
AHUser (developer)
2006-02-21 05:04

There is a bug in the VCL causing bitmaps loaded from a resource to leak. The JVCL has a work around for this for some time now.

- Issue History
Date Modified Username Field Change
2005-07-03 21:21 anonymous New Issue
2005-07-04 13:22 obones Note Added: 0007525
2005-07-04 13:22 obones Status new => feedback
2005-07-05 03:00 anonymous Note Added: 0007526
2005-07-06 19:04 waskol Note Added: 0007533
2005-07-07 04:12 waskol Note Added: 0007535
2005-07-07 04:13 waskol Note Edited: 0007535
2005-07-07 04:13 waskol Note Edited: 0007535
2005-07-11 01:15 waskol Note Added: 0007544
2005-08-04 09:41 François Note Added: 0007661
2006-02-21 05:04 AHUser Status feedback => resolved
2006-02-21 05:04 AHUser Resolution open => fixed
2006-02-21 05:04 AHUser Assigned To => AHUser
2006-02-21 05:04 AHUser Note Added: 0008585


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker