Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003154 [JEDI VCL] 00 JVCL Components feature always 2005-08-17 04:19 2005-08-28 09:31
Reporter eswarpr View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003154: JvHLEditor - Parser features for HTML and SQL
Description I am trying to get the TJvHLEditor component to hilight my SQL comments starting with "--". I guess this was not available in version 3.00 and also multi-line HTML comment which goes like <!-- Comment -->. I have put in the fix for the -- comments, but since I am not a "developer" to JVCL yet, I don't know how to upload the fix which pretty much covers the JvHLEditor.pas and JvParser.pas. How do I do this?
Additional Information
Tags No tags attached.
Attached Files txt file icon jvhleditor_diff.txt [^] (5,948 bytes) 2005-08-18 04:37
txt file icon jvunicodehleditor_diff.txt [^] (5,477 bytes) 2005-08-18 04:38
txt file icon jvhlparser_diff.txt [^] (2,807 bytes) 2005-08-18 04:38
txt file icon jvhleditor_diff_new.txt [^] (5,948 bytes) 2005-08-19 02:56
txt file icon jvhlparser_diff_new.txt [^] (2,807 bytes) 2005-08-19 02:56
txt file icon jvunicodehleditor_diff_new.txt [^] (5,477 bytes) 2005-08-19 02:56

- Relationships

-  Notes
(0007806)
obones (administrator)
2005-08-17 05:08

HT is for HTML, hence, the SQL comments are not to be taken into account.
The multiline <!-- comments should, however, be taken into account.
If you can get the latter to work, please upload a diff file (diff -u 3) to this server and we'll look into it.
(0007807)
eswarpr (reporter)
2005-08-17 05:20
edited on: 2005-08-17 05:22

Thanks. I will try to get the <!-- comments to work in it. For the SQL comments, I thought JvHLEditor has more than one "mode" which includes hlSql hilighter that comes default with the JvHLEditor component. In that case shouldn't it be taken into account? One keyword missing by the parser for SQL is "replace" as in "create or replace". I have entered in that too. But even then, is it OK if my fix comes with it?

PS: I am new to using CVS diff, since I don't use UNIX or LINUX at home. Any pointers to a "diff" port for win32 would be greatly appreciated.

(0007808)
obones (administrator)
2005-08-18 00:48
edited on: 2005-08-18 00:49

Woops, sorry, I misread the report, it's JvHLEditor, not the JvHTLabel.
So yes, please bring in the change for SQL as well.

As to diff, there is a port of a bunch of unix tools for Win32, it's called unxutils on sourceforge:

http://unxutils.sourceforge.net/ [^]

Beware to not put the echo program in this package inside a directory accessible by PATH as it behaves differently from the regular echo and would be used instead of this default one. Same goes for make, by the way.

(0007809)
eswarpr (reporter)
2005-08-18 04:41

There are 3 files that I have changed JvHLEditor.pas, JvHLParser.pas, and JvUnicodeHLEditor.pas and have added support for the -- SQL comment, the SQL replace keyword and <!-- --> comment for HTML hilighter. I have uploaded them as output files of the diff -u3 command on the files. This is the first time I am uploading my code to sourceforge.net bug tracker. Let me know if this is the correct way to do it, or please suggest changes.
(0007811)
obones (administrator)
2005-08-18 09:03

The files were uploaded just fine, but the diff is in reverse.
The order in which you specify on the command lines is important as it indicates you are going from one file to the other.
Basically, those updated here, have '-' (minus) in front of the lines you added, where it should have been '+' (plus). Could you try to do this again?
I mean, I could do it myself, but then, you wouldn't learn much from this exchange ;-)
(0007814)
eswarpr (reporter)
2005-08-19 02:57

Thanks. I have uploaded the new versions as *_diff_new.txt files. Let me know if I did right.
(0007815)
obones (administrator)
2005-08-19 03:26

Yes, they are fine, I'll put that in CVS when I get a bit of spare time
(0007871)
obones (administrator)
2005-08-28 09:31

This is now in CVS.
As you will have noticed, the "eswar" comments got adapted as we generally don't do "in source" acknowledgment. Your name has however been added to the contributors list for those units.

- Issue History
Date Modified Username Field Change
2005-08-17 04:19 eswarpr New Issue
2005-08-17 05:08 obones Note Added: 0007806
2005-08-17 05:08 obones Status new => feedback
2005-08-17 05:20 eswarpr Note Added: 0007807
2005-08-17 05:22 eswarpr Note Edited: 0007807
2005-08-18 00:48 obones Note Added: 0007808
2005-08-18 00:49 obones Note Edited: 0007808
2005-08-18 04:37 eswarpr File Added: jvhleditor_diff.txt
2005-08-18 04:38 eswarpr File Added: jvunicodehleditor_diff.txt
2005-08-18 04:38 eswarpr File Added: jvhlparser_diff.txt
2005-08-18 04:41 eswarpr Note Added: 0007809
2005-08-18 09:03 obones Note Added: 0007811
2005-08-19 02:56 eswarpr File Added: jvhleditor_diff_new.txt
2005-08-19 02:56 eswarpr File Added: jvhlparser_diff_new.txt
2005-08-19 02:56 eswarpr File Added: jvunicodehleditor_diff_new.txt
2005-08-19 02:57 eswarpr Note Added: 0007814
2005-08-19 03:26 obones Note Added: 0007815
2005-08-28 09:31 obones Status feedback => resolved
2005-08-28 09:31 obones Resolution open => fixed
2005-08-28 09:31 obones Assigned To => obones
2005-08-28 09:31 obones Note Added: 0007871


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker