Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003168 [JEDI VCL] 00 JVCL Components minor always 2005-08-27 09:06 2005-08-31 01:25
Reporter CRoeper View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003168: TJvCustomAppStorage (unit JvAppStorage) destructor always does a flush.
Description Maybe I am missing something, but every AppStorage component does save all properties and data when the application is closed.
This is because in the TJvCustomAppStorage.Destroy method the Flush method is called.
Is this by design!?
I would have thought that this is what the AutoFlush property is for, when set to TRUE Flush is called on every change and on close; when set to FALSE the developer has to call Flush by himself.
Additional Information I would suggest to change the first line of the destructor to the following code:

destructor TJvCustomAppStorage.Destroy;
begin
  if FAutoFlush then Flush;
[...]
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007849)
obones (administrator)
2005-08-28 03:29

Yes, this is by design, for historical reasons. It has been discussed in the newsgroups a while back and left this way to keep compatibility.
Would adding "property FlushOnDestroy: Boolean" be ok with you?
(0007891)
elahn (developer)
2005-08-29 18:27

Adding "property FlushOnDestroy: Boolean" would be excellent!
(0007893)
CRoeper (reporter)
2005-08-30 11:17

Yes, adding a new property like "FlushOnDestroy" is perfect - if it has the same effect. Thanks!
(0007898)
obones (administrator)
2005-08-31 01:25

Ok then.
This is now in CVS, the property FlushOnDestroy has been added, its default value being True.

- Issue History
Date Modified Username Field Change
2005-08-27 09:06 CRoeper New Issue
2005-08-28 03:29 obones Note Added: 0007849
2005-08-28 03:29 obones Status new => feedback
2005-08-29 18:27 elahn Note Added: 0007891
2005-08-30 11:17 CRoeper Note Added: 0007893
2005-08-31 01:25 obones Status feedback => resolved
2005-08-31 01:25 obones Resolution open => fixed
2005-08-31 01:25 obones Assigned To => obones
2005-08-31 01:25 obones Note Added: 0007898


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker