Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003251 [JEDI VCL] 00 JVCL Components major always 2005-10-03 16:38 2005-10-12 15:05
Reporter Peter Sanders View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003251: JvSpeedBar Editor does not work correctly
Description Editor allows the creation of sections and buttons. Buttons placed on the toolbar cannot be "dragged off" the toolbar, buttons cannot be repositioned on the toolbar.

Buttons on the toolbar cannot be selected, the "whole" toolbar is selected when a button is clicked.
Additional Information It may only be the fact that the buttons cannot be selected that is the cause of the problem. If the button could be selected the dragging and repositioning may function again as normal.

Previously the editor used to remain visible during the dragging on to and from the toolbar. Currently the editor disappears behind the form containing the toolbar when any attempt to select a button is made.

It seems to me that an attempt to select a button causes the toolbar to receive the focus.

A sample app is attached but it should be reproduceable on others' pcs.

Regards

Peter Sanders
Tags No tags attached.
Attached Files zip file icon JvTbTest.zip [^] (1,772 bytes) 2005-10-03 16:38

- Relationships

-  Notes
(0008003)
remkobonte (developer)
2005-10-05 14:08

The problem is the

if not DispatchIsDesignMsg(Self, Msg) then

line in the WndProc method of the TJvExCustomPanel class in JvExExtCtrls.pas. It determines that mouse messages at design time should not go to the control.

If you remove that line, the control works as expected. I think this line is needed for something so I'm not sure how to resolve this issue.
(0008021)
remkobonte (developer)
2005-10-12 14:07

Reminder sent to: AHUser

Could you look at bug report 0003251 in Mantis. It is about JvExExtCtrls.pas and I'm not sure how to fix it.
(0008022)
AHUser (developer)
2005-10-12 15:05

> I think this line is needed for something

Without this line many components will react on messages which normally the form designer would catch.

I fixed this bug by skipping the IsDesignMsg() call if any of the "allowed" (see TWinControl.WndProc) messages are received.


Fixed in CVS

- Issue History
Date Modified Username Field Change
2005-10-03 16:38 Peter Sanders New Issue
2005-10-03 16:38 Peter Sanders File Added: JvTbTest.zip
2005-10-05 14:08 remkobonte Note Added: 0008003
2005-10-12 14:07 remkobonte Issue Monitored: AHUser
2005-10-12 14:07 remkobonte Note Added: 0008021
2005-10-12 15:05 AHUser Status new => resolved
2005-10-12 15:05 AHUser Resolution open => fixed
2005-10-12 15:05 AHUser Assigned To => AHUser
2005-10-12 15:05 AHUser Note Added: 0008022
2007-12-16 11:19 AHUser Issue End Monitor: AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker