Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003308 [JEDI VCL] 00 JVCL Components major always 2005-11-10 00:45 2005-11-22 05:20
Reporter DeathMAD View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003308: Design Editor for TJvImageList produce design-time error - "Invalid typecast"
Description Code in file JvDsgnEditors

procedure TJvImageListEditor.ExecuteVerb(Index: Integer);
begin
  if Designer <> nil then
    case Index of
      0:
        if EditImageList(Component as TImageList) then //---error, TJvImageList
                                                       //inherits from
                                                       //TCustomImageList, but
                                                       // not from TImageList
          Designer.Modified;
      1:
        SaveAsBitmap(TImageList(Component));
    end;
end;

Solution - "if EditImageList(TImageList(Component)) then"
But that is ugly IMHO.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008115)
AHUser (developer)
2005-11-22 05:20

Fixed in CVS.

The hard typecast should be OK, because the VCL's TCustomImageList editor is also the normal TImageList editor.

- Issue History
Date Modified Username Field Change
2005-11-10 00:45 DeathMAD New Issue
2005-11-22 05:20 AHUser Status new => resolved
2005-11-22 05:20 AHUser Resolution open => fixed
2005-11-22 05:20 AHUser Assigned To => AHUser
2005-11-22 05:20 AHUser Note Added: 0008115


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker