Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003348 [JEDI VCL] 00 JVCL Components crash always 2005-12-08 14:11 2006-06-28 13:31
Reporter elahn View Status public  
Assigned To elahn
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003348: AV in JvInspector when the same object is referenced twice
Description This occurs when the same object is referenced in 2 different places. When "InspectObject := nil", an AV occurs.

Attached is a demo of this bug. Simply click "Assign" then "Assign to Nil" to generate it.
Additional Information
Tags No tags attached.
Attached Files zip file icon JvInspectorTest2.zip [^] (1,396 bytes) 2005-12-08 14:11

- Relationships

-  Notes
(0008893)
obones (administrator)
2006-04-04 07:09

I'm seeing this, but I'm not sure if it's a "feature" or a serious bug. First of all I don't see a situation where this could occur in "real life", but I'm not using the inspector that much. As such, I would appreciate any insights.
(0008917)
elahn (developer)
2006-04-04 11:51

This happens all the time for me...I have structured data classes, where certain data objects are referenced by multiple objects. Sorry I can't be more specific, but it's confidential.

In order to work around it, I don't display the properties of certain object types in the Inspector, the user must double-click the item to open it in a new Inspector window in order to view it's contents. This has limited the design of my data structure, but I have no way of knowing the degree.

Hypothetical example: address book groups - each Group contains multiple Person objects, and a Person can be a member of multiple groups.

Another example: a log of events; each event references the object involved. Since over time many events could occur involving that object, it would occur multiple times in the Inspector.
(0009665)
obones (administrator)
2006-06-27 03:50

Can you investigate and possibly find a solution?
(0009706)
elahn (developer)
2006-06-28 02:33

Commenting out the contents of TJvInspectorPropData.NotifyRemoveData() solves the issue and doesn't appear to cause a memory leak. However, I don't know the reason this code is there, do you?
(0009717)
marcelb (manager)
2006-06-28 12:43

It's been a long time when I wrote it. I'm pretty sure I know what the reason was, but for the life of me can't figure out how I intended it to perform.

Anyway, if no memory is being leaked, I suggest to comment it out for now. I'll see if I can figure it out and get back to this later.

--
Marcel
(0009718)
elahn (developer)
2006-06-28 13:31

Commented out in SVN revision 10757.

- Issue History
Date Modified Username Field Change
2005-12-08 14:11 elahn New Issue
2005-12-08 14:11 elahn File Added: JvInspectorTest2.zip
2006-04-04 07:09 obones Note Added: 0008893
2006-04-04 07:09 obones Status new => confirmed
2006-04-04 11:51 elahn Note Added: 0008917
2006-06-27 03:50 obones Note Added: 0009665
2006-06-28 02:33 elahn Note Added: 0009706
2006-06-28 12:43 marcelb Note Added: 0009717
2006-06-28 13:31 elahn Status confirmed => resolved
2006-06-28 13:31 elahn Resolution open => fixed
2006-06-28 13:31 elahn Assigned To => elahn
2006-06-28 13:31 elahn Note Added: 0009718


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker