Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003492 [JEDI VCL] 00 JVCL Components major always 2006-02-07 02:56 2006-02-18 03:51
Reporter silent-ghost View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003492: TJvXPBar: OnDblClick don´t work
Description The OnDblClick event don't work. When i dblclick on a Item or the TJvXPBar Caption, nothing will happen.
Additional Information
Tags No tags attached.
Attached Files zip file icon 3492.zip [^] (4,293 bytes) 2006-02-15 11:28

- Relationships

-  Notes
(0008563)
Samuel Herzog (reporter)
2006-02-15 11:15

It does not work because in the constructor the componentstyle is set to

- [csDoubleClicks]

See below:

constructor TJvXPCustomWinXPBar.Create(AOwner: TComponent);
const
  MouseEvents: TJvXPControlStyle = [csRedrawMouseEnter, csRedrawMouseLeave];
begin
  inherited Create(AOwner);
  FStoredHint := '|'; // no one in their right mind uses a pipe as the only character in a hint...
  ControlStyle := ControlStyle - [csDoubleClicks] + [csAcceptsControls, csActionClient];
(0008569)
AHUser (developer)
2006-02-18 03:51

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2006-02-07 02:56 silent-ghost New Issue
2006-02-08 10:13 obones Summary OnDblClick don´t work => TJvXPBar: OnDblClick don´t work
2006-02-15 11:15 Samuel Herzog Note Added: 0008563
2006-02-15 11:28 Samuel Herzog File Added: 3492.zip
2006-02-18 03:51 AHUser Status new => resolved
2006-02-18 03:51 AHUser Resolution open => fixed
2006-02-18 03:51 AHUser Assigned To => AHUser
2006-02-18 03:51 AHUser Note Added: 0008569


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker