Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003498 [JEDI VCL] 02 Installation feature always 2006-02-09 07:36 2007-05-20 02:31
Reporter outchy View Status public  
Assigned To AHUser
Priority low Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003498: Disable unsupported packages for personal versions
Description The installation of the JVCL fails on personal SKU of Delphi because it doesn't have support for databases. It would be great to disable these packages (they are all checked when a "new installation" is started)
Additional Information
Tags No tags attached.
Attached Files png file icon Untitled-Captured-01.png [^] (39,704 bytes) 2007-01-02 15:18

- Relationships

-  Notes
(0008642)
AHUser (developer)
2006-03-10 02:33

JVCL 3.10 was released for the BDS 2006 Companion CD and not tested against Standard/Personal SKUs. After the release we have updated all the Package-XML files that now support Personal SKUs again.
(0008695)
outchy (administrator)
2006-03-19 12:49

On my computer, the installation fails when I select a personal version of Delphi. I have to manually unselect packages that require database support (JvUIB, JvDB, JvInspector...), these packages should be automatically unchecked.
(0008696)
outchy (administrator)
2006-03-19 12:50

Note: I deleted JVCLInstall.ini before launching the installation process.
(0009029)
obones (administrator)
2006-04-07 07:26

Any news on this guys?
(0009036)
outchy (administrator)
2006-04-07 09:03

All packages are still enabled by default for personal versions of Delphi/BCB/BDS.
(0010480)
obones (administrator)
2007-01-02 06:39

Is this still true?
(0010486)
outchy (administrator)
2007-01-02 15:20

I have to say yes
(0012814)
AHUser (developer)
2007-05-20 02:31

The "Personal Edition" detection code couldn't handle "Personnel". It only looked for "Personal", "STD", "PER" and "PERS".
I have change the implementation to look for the db.dcu file. This will also work around the problem that some persons have because their registry value for "EDITION" is empty.

- Issue History
Date Modified Username Field Change
2006-02-09 07:36 outchy New Issue
2006-03-10 02:33 AHUser Status new => resolved
2006-03-10 02:33 AHUser Resolution open => fixed
2006-03-10 02:33 AHUser Assigned To => AHUser
2006-03-10 02:33 AHUser Note Added: 0008642
2006-03-19 12:49 outchy Status resolved => feedback
2006-03-19 12:49 outchy Resolution fixed => reopened
2006-03-19 12:49 outchy Note Added: 0008695
2006-03-19 12:50 outchy Note Added: 0008696
2006-04-07 07:26 obones Note Added: 0009029
2006-04-07 09:03 outchy Note Added: 0009036
2007-01-02 06:39 obones Note Added: 0010480
2007-01-02 15:18 outchy File Added: Untitled-Captured-01.png
2007-01-02 15:20 outchy Note Added: 0010486
2007-05-20 02:31 AHUser Status feedback => resolved
2007-05-20 02:31 AHUser Fixed in Version => Daily / SVN
2007-05-20 02:31 AHUser Resolution reopened => fixed
2007-05-20 02:31 AHUser Note Added: 0012814


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker