Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003718 [JEDI VCL] 00 JVCL Components minor sometimes 2006-05-22 00:31 2006-06-09 03:01
Reporter thehangedman View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003718: TJvNetscapeSplitter highlighting
Description TJvNetscapeSplitter highlighting occasionally fails when AllowDrag=false (with default other properties)
Additional Information When AllowDrag is set to false, highlighting takes place when MouseEnter occurs with mouse position of a netscape button, otherwise it doesn't.

The suggested solution is putting the highlight checking out of "if AllowDrag then" statement in TJvCustomNetscapeSplitter.WMMouseMove:

procedure TJvCustomNetscapeSplitter.WMMouseMove(var Msg: TWMMouseMove);
begin
  if AllowDrag then
  begin
    inherited;
  end
  else
    DefaultHandler(Msg); // Bypass TSplitter and just let normal handling
    // The order is important here. ButtonHitTest must be evaluated before
    // the ButtonStyle because it will change the cursor (over button or not).
    // If the order were reversed, the cursor would not get set for bsWindows
    // style since short-circuit Boolean eval would stop it from ever being
    // called in the first place.
    if ButtonHitTest(Msg.XPos, Msg.YPos) and (ButtonStyle = bsNetscape) then
    begin
      if not FIsHighlighted then
        PaintButton(True)
    end
    else
    if FIsHighlighted then
      PaintButton(False);
// end
// else
// DefaultHandler(Msg); // Bypass TSplitter and just let normal handling occur.
end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009522)
obones (administrator)
2006-06-09 03:01

This is now in SVN

- Issue History
Date Modified Username Field Change
2006-05-22 00:31 thehangedman New Issue
2006-06-09 03:01 obones Status new => resolved
2006-06-09 03:01 obones Resolution open => fixed
2006-06-09 03:01 obones Assigned To => obones
2006-06-09 03:01 obones Note Added: 0009522


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker