Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003794 [JEDI VCL] 00 JVCL Components minor always 2006-07-02 10:41 2006-07-03 10:04
Reporter esasse View Status public  
Assigned To Informatix
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003794: JvDBGrid: Clicking the TitleArrow doesn't show the SelectColumnsDialog if DataSet is Closed
Description If the grid has columns, I think the SelectColumnsDialog should be shown, even if the DataSet is closed.

When I fire it by code (Grid.ShowColumnsDialog), it works perfectly with the DataSet closed so I think there is no problem to show it when the TitleArrow is clicked.

My suggested change in code is this:

In the TJvDBGrid.MouseUp, replace the check for DataLink.Active, to (Columns.Count > 0), so the code looks like this:

  if FTitleArrow and (Button = mbLeft) and
    (dgTitles in Options) and (dgIndicator in Options) and
    (Cell.X = 0) and (Cell.Y = 0) and (Columns.Count > 0) then
    ShowSelectColumnClick; // Selection of columns
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009754)
Informatix (developer)
2006-07-03 10:03

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2006-07-02 10:41 esasse New Issue
2006-07-02 10:46 esasse Description Updated
2006-07-02 10:58 esasse Description Updated
2006-07-03 08:20 obones Assigned To => Informatix
2006-07-03 08:20 obones Status new => acknowledged
2006-07-03 10:03 Informatix Note Added: 0009754
2006-07-03 10:04 Informatix Status acknowledged => resolved
2006-07-03 10:04 Informatix Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker