Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003818 [JEDI VCL] 00 JVCL Components feature always 2006-07-20 13:27 2007-10-12 06:48
Reporter Karlheinz View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003818: Decimal Rounding for TJvValidateEdit
Description Is it possible to add the decimal rounding function from John Herbster
or is it possible to add an event handler to modify the screen output only?

Please have a look at

http://codecentral.borland.com/Item.aspx?ID=21909 [^]
Additional Information
Tags No tags attached.
Attached Files ? file icon JvValidateEdit.pas [^] (47,476 bytes) 2007-06-23 03:48
7z file icon TestDecimalRounding.7z [^] (6,532 bytes) 2007-06-23 04:44

- Relationships

-  Notes
(0009824)
obones (administrator)
2006-07-21 01:09

I'm sorry, but I don't understand what is wrong with the current behaviour. An example would be most welcome.
(0009832)
Karlheinz (reporter)
2006-07-21 07:49

Nothing is wrong today, but I have problems with the optical accuracy for e.g. 2.000 is shown as 1.999.
If you have a look at the link you can see the reasons behind.
I think it would be a good feature to add this function or to have an event handler so I can call the function before the value is drawn at the edit field.
(0010496)
obones (administrator)
2007-01-03 12:27

Can you figure out a simple way to add it to the current version?

http://jvcl.sf.net/daily/ [^]
(0013412)
obones (administrator)
2007-06-19 04:49

Any news?
(0013516)
Karlheinz (reporter)
2007-06-23 03:50
edited on: 2007-06-23 04:46

I have added a new eventhandler "OnDecimalRounding" to JvValidateEdit.

Please have a look at the attached file and the small test application.

(0013916)
obones (administrator)
2007-10-12 06:48

This is now in SVN

- Issue History
Date Modified Username Field Change
2006-07-20 13:27 Karlheinz New Issue
2006-07-21 01:09 obones Note Added: 0009824
2006-07-21 01:09 obones Status new => feedback
2006-07-21 07:49 Karlheinz Note Added: 0009832
2007-01-03 12:27 obones Note Added: 0010496
2007-06-19 04:49 obones Note Added: 0013412
2007-06-23 03:48 Karlheinz File Added: JvValidateEdit.pas
2007-06-23 03:50 Karlheinz Note Added: 0013516
2007-06-23 04:44 Karlheinz File Added: TestDecimalRounding.7z
2007-06-23 04:46 Karlheinz Note Edited: 0013516
2007-10-12 06:48 obones Status feedback => resolved
2007-10-12 06:48 obones Fixed in Version => Daily / SVN
2007-10-12 06:48 obones Resolution open => fixed
2007-10-12 06:48 obones Assigned To => obones
2007-10-12 06:48 obones Note Added: 0013916


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker