Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003819 [JEDI VCL] 00 JVCL Components block always 2006-07-20 13:45 2006-07-24 03:35
Reporter Karlheinz View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003819: Problems with TJvTimer in TJvAnimatedImage
Description The problem of the IDE bug is solved now.
Delphi 7 at W2K

But I have the following problems:
1. If I set the active property in TJvAnimatedImage to FALSE, I get with FastMM the message FastMM has detected an attempt to call a virtual method on a freed object => see the informations below.

2. If I set the active property in TJvAnimatedImage to TRUE and I close the form the main form (or application?) did not work anymore.
Additional Information --------------------------------2006/7/20 21:32:16--------------------------------
FastMM has detected an attempt to call a virtual method on a freed object. An access violation will now be raised in order to abort the current operation.

Freed object class: TCriticalSection

Virtual method: Offset +4

Virtual method address: 44FED0

The allocation number was: 146360

Stack trace of when the object was allocated (return addresses):
402EFC [system.pas][System][@GetMem][2439]
4040E7 [system.pas][System][TObject.NewInstance][8360]
4044D2 [system.pas][System][@ClassCreate][9019]
44FE3A [SyncObjs.pas][SyncObjs][TCriticalSection.Create][194]
4040F0 [system.pas][System][TObject.NewInstance][8360]
4044D2 [system.pas][System][@ClassCreate][9019]
690824 [JvTimer.pas][JvTimer][TJvTimerThread.Create][120]
690A32 [JvTimer.pas][JvTimer][TJvTimer.Create][226]
4319F0 [classes.pas][Classes][CreateComponent][6096]

Stack trace of when the object was subsequently freed (return addresses):
402F27 [system.pas][System][@FreeMem][2466]
404105 [system.pas][System][TObject.FreeInstance][8366]
40451D [system.pas][System][@ClassDestroy][9060]
44FEB1 [SyncObjs.pas][SyncObjs][TCriticalSection.Destroy][202]
40414B [system.pas][System][TObject.Free][8385]
6908CF [JvTimer.pas][JvTimer][TJvTimerThread.Destroy][161]
40414B [system.pas][System][TObject.Free][8385]
690AAA [JvTimer.pas][JvTimer][TJvTimer.Destroy][240]
436F35 [classes.pas][Classes][TComponent.DestroyComponents][9853]

The current stack trace leading to this error (return addresses):
6909CE [JvTimer.pas][JvTimer][TJvTimerThread.Execute][208]
436555 [classes.pas][Classes][ThreadProc][9372]
402F27 [system.pas][System][@FreeMem][2466]
404F82 [system.pas][System][ThreadWrapper][11554]
77E7B388 [lstrcmpiW]
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0009820)
obones (administrator)
2006-07-21 01:02

Point 1 is now fixed in SVN.
Point 2 needs a demo application, I cannot reproduce it.
(0009837)
Karlheinz (reporter)
2006-07-21 12:50
edited on: 2006-07-23 05:52

I am not sure if the following is the same as point 2 but it happens directly inside of the IDE.
1. create a new form
2. add a TJvAnimatedImage, Active is false by default
3. Start the windows taskmanager and check the CPU load for Delphi (should be very low)
4. switch Active in the Objectinspector to true => CPU Load is low after a second
5. switch Active to false => CPU load is very high (80 - 98% at PentiumIII 800 MHz, W2k; Delphi7)
6. switch Active to true => CPU load is low (4-8%)
7. I can do that several times with the same result

(0009848)
obones (administrator)
2006-07-24 03:35

All points are now fixed in SVN.
Original point 2 was a result of another issue (IDE deadlock), and point mentionned in note has been addressed.

- Issue History
Date Modified Username Field Change
2006-07-20 13:45 Karlheinz New Issue
2006-07-21 01:02 obones Note Added: 0009820
2006-07-21 01:02 obones Status new => feedback
2006-07-21 12:50 Karlheinz Note Added: 0009837
2006-07-23 05:52 Karlheinz Note Edited: 0009837
2006-07-24 03:35 obones Status feedback => resolved
2006-07-24 03:35 obones Fixed in Version => Daily / SVN
2006-07-24 03:35 obones Resolution open => fixed
2006-07-24 03:35 obones Assigned To => obones
2006-07-24 03:35 obones Note Added: 0009848


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker