Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004391 [JEDI VCL] 00 JVCL Components major always 2008-07-04 03:52 2008-11-02 15:10
Reporter ARaim View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0004391: TJvInspector - Editing the caption property for objects of type TSpeedButton does not trigger event
Description Steps to repro:

-> Create a new VCL application
-> Drop a TJvInspector on the form
-> Drop a TSpeedButton on the form
-> Handle form's OnCreate event, adding this line of code: JvInspector1.InspectObject := SpeedButton1;
-> Add an event handler for OnItemValueChanged event.
-> Change properties, when you'll change the caption you'll notice that the event does not fire.
Additional Information I suspect other components and controls will have the same behaviour, but I didn't check as of yet.
Tags No tags attached.
Attached Files zip file icon rp4391.zip [^] (4,390 bytes) 2008-07-04 06:38

- Relationships

-  Notes
(0014366)
obones (administrator)
2008-07-04 05:21

Hi,

I would make our life easier if you could upload the zipped sources of a sample application showing this.

Thanks
(0014368)
ARaim (reporter)
2008-07-04 06:39

I uploaded it, despite reaffirming that I don't see how having a sample project with just one line of code may help diagnosing an issue that is likely to be originated elsewhere.

Andrew
(0014369)
obones (administrator)
2008-07-04 06:46

Because it saves us the time of creating it, and sometimes it's not the line, but the properties in the DFM that are the source of the problem.
Right now, I have the time to do "housekeeping" in Mantis, but not the time to look at solving any issue directly. But when the time comes, I only have to download the APP, try it and see what happens.
(0014954)
AHUser (developer)
2008-11-02 15:09

Fixed in SVN. The problem is that for String items the Item-editor uses the AutoUpdate=True setting. This causes DisplayValue and EditCtrl.Text to be synchronized before they are compared.

- Issue History
Date Modified Username Field Change
2008-07-04 03:52 ARaim New Issue
2008-07-04 05:21 obones Note Added: 0014366
2008-07-04 05:21 obones Status new => feedback
2008-07-04 06:38 ARaim File Added: rp4391.zip
2008-07-04 06:39 ARaim Note Added: 0014368
2008-07-04 06:46 obones Note Added: 0014369
2008-10-29 06:23 obones Status feedback => acknowledged
2008-11-02 15:09 AHUser Status acknowledged => resolved
2008-11-02 15:09 AHUser Fixed in Version => Daily / SVN
2008-11-02 15:09 AHUser Resolution open => fixed
2008-11-02 15:09 AHUser Assigned To => AHUser
2008-11-02 15:09 AHUser Note Added: 0014954


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker