Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004521 [JEDI VCL] 00 JVCL Components feature always 2008-10-10 08:29 2008-11-02 10:37
Reporter AlArt View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.35
Summary 0004521: TJvHLEditor is not performing Global Copy/Paste
Description TJvHLEditor is not reacting for the global clipboard events
Additional Information
Tags No tags attached.
Attached Files rar file icon 4.rar [^] (5,666 bytes) 2008-10-13 11:40

- Relationships

-  Notes
(0014840)
obones (administrator)
2008-10-12 23:49

Please post the zipped sources of a sample application showing this issue.
(0014849)
AlArt (reporter)
2008-10-13 11:40

here you go
(0014850)
AlArt (reporter)
2008-10-13 11:40

here you go
(0014863)
n9zle (reporter)
2008-10-15 10:09

This is the same as 0004528 The problem is in GetSelText I bet AlArt is using D2009

Thanks..
(0014864)
AlArt (reporter)
2008-10-15 11:11

You lost your bet. It is in D2007
(0014878)
AHUser (developer)
2008-10-18 03:00

There is no way to support the TEditAction actions. The TEditAction require a TCustomEdit derived class but TJvEditor is derived from TCustomControl.
(0014949)
AHUser (developer)
2008-11-02 10:35

I have now added new standard edit actions that support TCustomEdit and TJvCustomEditorBase. They are registered in the category "JVCL Edit".

This means that you have to replace your old standard edit actions by the JVCL ones which are 100% compatible with the old actions (and contain some bugfixes)

- Issue History
Date Modified Username Field Change
2008-10-10 08:29 AlArt New Issue
2008-10-12 23:49 obones Note Added: 0014840
2008-10-12 23:49 obones Status new => feedback
2008-10-13 11:40 AlArt File Added: 4.rar
2008-10-13 11:40 AlArt Note Added: 0014849
2008-10-13 11:40 AlArt Note Added: 0014850
2008-10-15 10:09 n9zle Note Added: 0014863
2008-10-15 11:11 AlArt Note Added: 0014864
2008-10-18 03:00 AHUser Note Added: 0014878
2008-11-02 10:35 AHUser Status feedback => resolved
2008-11-02 10:35 AHUser Fixed in Version => Daily / SVN
2008-11-02 10:35 AHUser Resolution open => fixed
2008-11-02 10:35 AHUser Assigned To => AHUser
2008-11-02 10:35 AHUser Note Added: 0014949


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker