Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004571 [JEDI VCL] 00 JVCL Components minor always 2008-11-07 06:52 2009-04-29 15:37
Reporter prmas View Status public  
Assigned To obones
Priority normal Resolution duplicate  
Status resolved   Product Version
Summary 0004571: JvRichEdit
Description Componet JvRichEdit is not showing the text formatted in Delphi 2009.

I insert " Hello! "

When access again. The Publisher shows the code:

{\rtf1\ansi\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}
\viewkind4\uc1\pard\lang1046\f0\fs16 Hello!!!\par
\'00\par
}

What it must make to correct this?

Best Regards,

Marcos Alves
Additional Information I am using JVCL 3.35 for Delphi 2009
Tags No tags attached.
Attached Files zip file icon JvRichEdit.zip [^] (111,460 bytes) 2008-11-28 18:04

- Relationships
duplicate of 0004632resolvedobones jvDBRichEdit shows rtf code instead of formatted text 

-  Notes
(0014981)
prmas (reporter)
2008-11-07 07:36

The error occurs in the JvDBRichEdit component.
(0015019)
obones (administrator)
2008-11-18 08:32

Please provide the zipped sources of a sample application showing this.
(0015068)
prmas (reporter)
2008-11-28 18:13

The example JvRichEdit was annexed.

FormShow event does not show the text formatted in Delphi 2009.

The same it occurs with component JvDBRichEdit.

I believe that the problem is related with the method " Editor.Lines.LoadFromStream" Because the button " Open"
it opens the archive correctly.

Tanks.

Marcos

- Issue History
Date Modified Username Field Change
2008-11-07 06:52 prmas New Issue
2008-11-07 07:36 prmas Note Added: 0014981
2008-11-18 08:32 obones Note Added: 0015019
2008-11-18 08:32 obones Status new => feedback
2008-11-28 18:04 prmas File Added: JvRichEdit.zip
2008-11-28 18:13 prmas Note Added: 0015068
2008-12-22 04:15 obones Relationship added related to 0004632
2009-04-29 15:36 obones Relationship replaced duplicate of 0004632
2009-04-29 15:37 obones Status feedback => resolved
2009-04-29 15:37 obones Resolution open => duplicate
2009-04-29 15:37 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker