Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004742 [JEDI VCL] 00 JVCL Components major always 2009-04-12 19:39 2009-04-15 21:23
Reporter sachse View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004742: "JvCsvData - Internal Limit of MAXCOLUMNS (120) reached. CSV Data has too many columns."
Description The testfile has 78 columns and 1300 lines (records).
The problem occurs because JvCsvData expect <CR> as record delimiter.
But the file contains only <LF> as delimiter usually in Unix/Linux.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015406)
sachse (reporter)
2009-04-12 19:42

Following fix works for me:

JvCsvData.pas:1209
----------------- snip ---------------
{
        if CrFlag and LfFlag and not QuoteFlag then
          Break;
}
        //CR+LF OR LF
        if (((CrFlag AND LfFlag)OR LfFlag) and (not QuoteFlag)) then Break;
----------------- snip ---------------
(0015408)
AHUser (developer)
2009-04-13 09:39

With boolean arithmetic you get:

if (((CrFlag AND LfFlag)OR LfFlag)... => if LfFlag and not QuoteFlag
(0015421)
AHUser (developer)
2009-04-15 21:23

Fixed in SVN.
The ReadLine method now accepts all three: CR, LF, CRLF. And it now does not include the line break char in the result string where it was cut but the called anyway.

- Issue History
Date Modified Username Field Change
2009-04-12 19:39 sachse New Issue
2009-04-12 19:42 sachse Note Added: 0015406
2009-04-13 09:39 AHUser Note Added: 0015408
2009-04-15 21:23 AHUser Note Added: 0015421
2009-04-15 21:23 AHUser Status new => resolved
2009-04-15 21:23 AHUser Fixed in Version => Daily / SVN
2009-04-15 21:23 AHUser Resolution open => fixed
2009-04-15 21:23 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker